Forum Academy Marketplace Showcase Pricing Features

RG user constraint on a Page

How to set a constraint on an RG for a specific user on a Profile Page? Here’s my setup:

1 DataType Photographer
2 DataType Gallery with a List of Photos
3 DataType Gallery is linked to Photographer

On the Details/Profile Page for Photographer, I have an RG set to Type: Image - which pulls a list of photos uploaded by a Photographer. The problem is all photographers that upload photos, their photos appear on the same Details/Profile Page as everyone else’s.

How can I make it so that only specific Photographers’ photos appear on the Details/Profile Page when they upload photos?

Thanks in advance

@KION2

Photo
Title (text)
Image (image)
Photographer (photographer)

Photographer
Name (text)
Gallery (gallery)

Gallery
Photographer (photographer)
Photos (List of photos)

Profile page
Type: photographer

RG in the profile page
Search for page’s photographer gallery list of photos

@cmarchan Thank much for your help… Did you try this on your end? Not working for me and I have tried all sorts of ways to do this, nada… Currently here’s what I have:

Photos
Photographer - Photographer
Image- List of images ( You had Image which I tried and didn’t work )

Gallery
Photographer - Photographer
Photos - Photos ( You had a List of Photos which didn’t work ) Photographer can upload multiple Images at a time so Photos needs to have a List of Images with a FieldType Image

Here’s the flow… From Photographers Dashboard, they click on an Icon to Add Photos - this takes them to a page where there’s 5 Picture Uploader. Upload Button workflow is et to Create a New Thing - Photos, since Photos has a FieldType Image set to a List of images, the only option is to add.

On the RG on the Page, Type of Content is set to Image. DataSource - Search for Gallery’s Photographers Gallery’s Photos Image.

Within the RG, there’s an Image Element set to Current Cell Image. Its not working even though I tried your method as well. Let me know if I am missing something, there has to be a way for this to work.

Kind regards

Everything else is set up correctly

Anyone know how to solve this?

Thanks