Safari - Clicking out of input field kicks the user up the page

Hi there, very strange thing happening with input fields in Safari.

This only appears in safari browser from what I can tell. I tested in Chrome and its fine.

But whenever I fill out an input field (or checkbox), and click out of it to the next input field (or anywhere on the page), the browser automatically scrolls up to the top of the page.

Has anyone else experienced this…?

@Bubble? Can you check this out please?


We’re looking into it

1 Like

Thanks @emmanuel! I’ll standby.

I just deployed a fix, it’ll be live within the hour. As always, give a shout if you encounter any related misbehavior.



I am also having this issue on Safari, despite the fix. :confused:

(Only have seen this issue on Safari too)

Hi @marca, it doesn’t appear the fix worked for me.

I’ve closed the window and re-launched, closed safari and re-opened, and still the “kick up” issue.

Quick update from our side, still experiencing the issue too.

I have the same issue on Safari, not on Chrome or Firefox.

Can one do you submit a new bug report? It seems the symptom is the same but the situation is different

1 Like

@Bubble We experienced the same issue, we’ve submitted a bug report last week with a test page:

Hi @emmanuel, I don’t think anyone else submitted a new bug report, so I just posted a “part 2” to this issue in “bug reports” here on the forum.

I have the same bug. But in my case it sets the view down the page.

It’s doing that now because there are tests being done behind the scene as they work to fix it.

Same thing happened last week, but the problem ultimately reverted back to the original kicking up (instead of down).

Just a quick update here.

The problem persists but I filed a bug ticket yesterday and have been reached out to by the bubble crew to let me know their engineers are working on it.

I’ll provide any updates as I get them. Hopefully won’t be long!

1 Like

I got a message from Bubble staff that a fix has been pushed for this. I did some testing and it appears the issue is resolved.

Is it working fine for everyone else?



From what we’ve seen problem solved.
Thank you !

1 Like

Issue fixed :wink:

1 Like

Yes it’s fixed for me as well :slight_smile:

1 Like

Yes, thank you for keeping us updated!

Awesome, thanks guys!