Forum Academy Marketplace Showcase Pricing Features

[solved] Logic for "make changes to a thing" not working

I have a table in my database called “calls” and a user logs call data into the call data table. However are multiple pages that the data is entered and/or updated.

I thought that I used the “make changes to a thing” correctly, but a number of inputs are not saving.

Here’s the process.

Step 1. Call is started. User select the type of call.

Hrere’s the workflow. This is where a call is created. All fields after this should be updating this call data.

Step 2. Specify the needs of the caller.

The next page specifies the needs of the caller.

Here is the workflow. Every time I update a call, I simply search for the last call that created/modified by the current user and then change some of the fields.

Step 3. Gather contact data. This is the same as step 2, but with different information.

The “customer need” field uses initial content from step 2.

Here’s the workflow for this step

Here’s the problem that I’m having.

When I look at the app data, not all of the information is being saved.

Here is the only information being saved.

I’m missing a lot of information that should have posted: Type of call from the first slide, Name, Phone.

What’s strange is I am getting address and email.

Any ideas on what I’m missing here?

Ok, it looks like I solved this myself. I’ll leave this up in case anyone else has the same issue.

This logic was correct. The issue was that I wasn’t displaying all of the data in the database.

I needed to click on the pencil/edit next to the call database and show all fields.