Forum Academy Marketplace Showcase Pricing Features

Solved - Possible to start typing into input form when user click an element?

I’m building a search feature where, on my main page I have a button saying “What are you looking for?”
When the user clicks on it I want to make a group visible which contain the actual search box.
As I don’t want the user having to click the search box again in order to start typing I want to execute a “start typing in this box when…is pressed” action.

Would it be possible to do this with current features or is it something that could be requested?

2 Likes

Solved.
I figured it out, that’s exactly what the ‘element actions - input - set focus’ action is used for.

1 Like

Any suggestions on troubleshooting why this isn’t working?

I’m trying to set the focus to the next input when a dropdown’s value is not empty. It works based on two different events if I run slow or step-by-step in the debugger. It also works the second time if I select an option in the dropdown and then select another one. It just doesn’t work the first time I select an option without the debugger; the focus doesn’t move to the input.

I see what you mean by it works the second time it does the same to me.

1 Like

I had better results with a workflow event: Dropdown’s value is changed and when This Dropdown’s value is not empty. Except it didn’t set the focus on page load.

Is this a bug?

I have the same thing: clicking a button should set focus to a search input field. It doesn’t work in regular preview, but it works using the workflow debugger set to step by step or slow…

@emmanuel, is this something you could look into? I can setup a test page if you want but from what I see most, if not everyone, is experiencing the same behaviour. For me it is in a popup with multiple inputs. I have it setup that ‘set focus’ should be focusing a search box, but instead it defaults to focusing on a second field in the popup. This is annoying as it requires a tap/click for each time this needs to be done (and that can be well over 150 times in each time).

When I run the debugger slow or step by step, the focus is set correctly. Would be cool if this could be fixed! Thanks.