[Solved] reset password workflow not working


I believe I have set up all the API stuff and SendGrid etc, but when I try to rest password, it says that it is sending an email, but nothing is received.

Any thoughts on this?

In terms of setting up my SendGrid key, it seems to be correct - Bubble have sent me their email saying that “This validates your settings”, so I am not sure why the action of resetting the password doesn’t cause an email to be sent…

Any help would be much appreciated, thanks, A

try to use this generating the token and sending of email from Backend workflow, It can works.

Have you checked your logs in SendGrid to see if the email is being sent or not?

1 Like

Hi Adam, have checked, they do not appear to be being sent, no…

So what is the reason they’re not being sent? The SendGrid logs should give you the reason…

(or are you saying there’s nothing in the logs at all)?

1 Like

I’m not sure - they are not appearing in the SendGrid log at all

Ah… ok … i see

In that case the issue is definitely not with SendGrid, but rather in your app.

So double check your workflows, and look at your App logs to see what’s going on there.

1 Like

The workflow is the standard one provided by Bubble

And the log shows this, which I would assume means that it should send the email?

Have you verified your sender identity on Sendgrid?

1 Like

The domain is authenticated, so yes. I haven’t authenticated the individual email, but I shouldn’t have to, surely that’s the point of domain authentication?

You are right, but you could give it a try :slight_smile:

1 Like

Haha, too true!

Did it. Unfortunately, still nothing.

So, with the help of the Bubble team, it is solved.

It turns out that I was testing the password reset with an email address that wasn’t in my database, so no email was sent out.

Once the email address was in, the reset email worked.

This topic was automatically closed after 70 days. New replies are no longer allowed.