Stripe charging amount with 2 extra zero's!

I am trying to figure out why stripe is not working properly for me. For e.g. I have a drop down that lets me select the following static values. 5,10,15,20,50

When I select one of these values and got to pay for this amount, Stripe actually charges me the above amount but with 2 extra 00. So I end up getting charged 500,1000,1500 etc.

On the stripe payment popup the figure is displayed correctly, see below:

This incorrect figure also shows up in my data display section.

I have no idea what it going on here. Tried everything including using customer states to convert to number etc but no use. Emmanuel also confirmed that there is no bug.

I also tried testing this in live mode. The system ended up charging me $500 instead of $5…

Eek that’s a serious problem. 2 extra 0’s is quite a difference!

I have no solid fix, but the two things that pop to mind immediately are

  1. would reaching out to stripe help?

and 2. maybe scratching the entire workflow and rework it?

Sorry I can’t be of more help, keep us posted!

I have sent an email to stripe however I suspect they will just tell me that it’s an issue with Bubble. I looked at the Post request and it seems like bubble is sending the request with the 2 extra zero’s added.

I will keep everyone updated.

Stripes amounts are in cents. I think that’s why you see 00. We use stripe and in the logs the personal plan charges are 1900.

1 Like

Just multiply by 100.

//for strippeBookAmt
var stripeBookAmt = bookDoc.bookPrice * 100;