Forum Academy Marketplace Showcase Pricing Features

Stripe Error Message

I’m getting this error message each time I try to make a payment.

I’ve implemented Stripe, and even though I filled in both the Secret Live Key and the Publishable Live Key in the Stripe Plugin section, when I try to make a payment, I get this error message pop up and cant proceed with the payment.

Anybody any ideas on how to solve this?

Well you should probably double check your keys, the stripe’s message is pretty clear (and independent from Bubble).

I did recheck and re-entered my keys around 20 times, and also got new keys from Stripe.

In Bubble, I get this error message even though I filled in my Secret key and publishable key in the Stripe Plugins tab.

Also, when I click on '‘enter your API keys’ it takes me to the Stripe API keys Plugin section, where I already filled in both my publishable and secret keys, but the error message still stays.

Could it be that my app was in test mode? I tried to go live to test that but it wont let me until I fix that error message.

Double-check to make sure that there isn’t a space at the end of your keys. That’s caused an issue for me when I copy/pasted my keys before.

2 Likes

Actually I triple checked that too, I also tried to just manually enter the keys instead of copy pasting it, didn’t work.

I contacted Stripe yesterday, their customer support said that I was able to successfully create tokens previously and then rolled my keys (got new keys), once I enter my new keys I should be able to make live charges,

But it doesn’t, I already entered the new keys multiple times without a typo mistake and it still gets me that error message saying I should get valid publishable keys.

Can you share a link to the editor?

Well it works for me…

One thing to note though, you should ABSOLUTELY enter your test keys, you don’t want to be testing with live keys, as it’s about real money.

(also, Josh and I have access to users’ apps for debugging/help purposes, and no-one else, so no need to open your app when it’s us. For others though, and if it’s not sensitive like API keys, it’s always better to open to get help).

1 Like

That’s weird, because at my side it still doesnt work, neither with test keys.

Do you mean that the checkout form works or do you mean that you were able to make/charge a test transaction?
Did you try to make a test payment?

I also switched my Stripe account back and forth to ‘‘Test mode’’ and live mode to test it out, neither worked.

Also, in my Bubble account, the red error message that says enter your API Keys doesnt go away, even though I filled in the API keys.

Well I can’t try to make a payment if you don’t enter your test keys.

Thats true, now I’;ve put in my test keys.

But even if you are able to make a transaction with the test keys in testmode, will it automatically also work in live?

Because I think I was able to make a test transaction past week, and then afterwards put in my live keys in live mode, and it didn’t work out.

I appreciate the help!

Well before the real launch you should test in live with real money.

I tried that, I’ve been putting my own creditcard in there, that’s why I changed the amount to 0,70cents.

Do you mean first publish the app, (if im able to publish it with the working test keys), and THEN testing it live with my own creditcard with real money?

Stripe’s Customer support has reached out to me, theyre saying to reach out to the developers of the Bubble Stripe Plugin.

I think thats you Emmanuel :stuck_out_tongue:

Well if you think there is a bug please file a bug report online. But:

  1. please redo the different steps and make sure things are clean
  2. please make sure you have nowhere some code you copied from Stripe’s site (in the header, HTML element, etc.).

Stripe is one of the most common plugins for users’ apps, we use it all the time for our app, and it works. So I’m 99% there an issue with the way you set it up.

1 Like

No, I dont think there is a bug, neither did I say such a thing.

All I want to know is why - at charge your current user - it doesnt read my Stripe API Keys when I clearly have entered them. Stripe even said it connected.

I did redo the different steps, I even re-set it up in another bubble app.
The same error of Please fill in your stripe api keys while I already entered them.

I also cant test it anymore because the stripe checkout form doesnt switch back to test mode even though I fill in my Test Api Keys.

Just try to create a new fresh APP, enter API, and validate. My theory is as you said, hidden code between code. Just a theory.

I took your advice and setted up a entirely new app, twice, it gets the same error message, it doesnt read my stripe API keys.

I also tried getting new ones to see if that works, didnt work, the error message stays.

As of the code, I removed any of the code on the page last week.

I literally tried everything I can think of.

What is the link? Why did you delete it?

Hi, the link is https://bubble.io/page?name=index&id=xyz2&tab=tabs-1

I was receiving some weird traffic to my unpublished bubble pages, since I have my Stripe API keys there, I thought it was better to remove the link from the public forum just in case.

Keeps working for me on different browsers.

Please also copy the keys in the dev section of the API.