Forum Academy Marketplace Showcase Pricing Features

Wierd Stripe Error

I am trying to “go live” on stripe and have assumed that I’m just supposed to remove the development cliend ID, secret key, and publishable key from the settings screen, but now I get this error here:

In the console:

Stripe error You did not provide an API key, though you did set your Authorization header to “null”. Using Bearer auth, your Authorization header should look something like ‘Authorization: Bearer YOUR_SECRET_KEY’. See https://stripe.com/docs/api#authentication for details, or we can help at https://support.stripe.com/.Clear errors

It was working fine before. All i’ve done was remove the development keys.

ALL keys are accurate.

Shot in the dark, but you said you removed the publishable key from the settings screen, but the error is saying you’ve not set a publishable key. Have you tried not removing the publishable key?

Keep the development publishable key in place? Even though it’s not in development any more and i’m trying to go live?

It’s been a long time since I messed with my stripe configs, but is there a live publishable key?

Yes:

Isn’t it when we go live in stripe we just toggle the switch on our stripe.com dashboard? Maybe you don’t need to change any of the key settings?

Doesn’t work.

How do you go live on Bubble for Stripe payments?

¯_(ツ)_/¯

My live app is built on code, not bubble. Sorry I couldn’t be of help

1 Like

Have you tried putting the development keys back in?

For my setup, I actually have development still in there with live keys. I don’t have any Client IDs, but I’m assuming you’re using Stripe Connect

Things you’ve probably done, but just in case:

  • Check your Production Client ID and URIs in Stripe Connect settings
  • Deploy the app
  • Roll your keys (in Stripe dashboard) to get new ones
  • Remove Client ID if you don’t need it

Gaby | Coaching Bubble

@natedogg I have, but it still gives me the yellow ‘test mode’ in the corner… which is why i tried to delete them assuming that this will automatically use the live keys instead… problem is it doesn’t work.

@romanmg I’m actually not using stripe connect, although the keys are there.

The issue seems to be on the Publishable Key. I have rolled it and it still won’t give me anything but the error.

Try removing the Client IDs? I have no Client IDs and ALL keys in there.

EDIT: Also, I’m sure you’ve checked this a bunch of times already, but maybe there’s a space at the beginning or end of your keys?

Yeah I’ve checked that.

When I remove the client ID’s, it asks me to verify the API key within the workflow screen:

Adding in the client ID’s clear this issue:

It appears like Bubble is stuck using the test keys, even though i’ve removed them. ?

You aren’t using the test version/preview of your app, right? Bubble should automatically use the test keys for your version-test URL and the live keys for the live version.

3 Likes

I am/was. I will try and use the live website.

Interesting. I had thought of that but figured it wouldn’t do it automatically.

Even ensured that the actual url was in place (but with /version-test) and it still did not work. Updating to live now as per your suggestion.

Yes, should be using live for live everything. Hope it works!

1 Like