Thing being created, inputs deleted automatically

Hi! I’ve looked at several posts but they all go unanswered or are asking about privacy settings which I’ve already checked.

I have not encountered this issue anywhere else in my app but I set up a simple reusable element pop-up to create a school. The workflow to create a thing is within the reusable element. I’ve watched the debugger several times and nothing seems amiss. The newly created school shows up for a split second in my table, then disappears. When I go to the database, there is a blank entry for the school with the time I added it, but none of the other details.




The only way for me to add this data type is to input values directly into the database.

Is this a bug? This is probably the simplest data type and entry procedure I have and it’s driving me nuts that it isn’t working!

Hi @abby_hc :wave:

Looking to your screen shots, I assume the issue may be related to the fact that, in some cases, workflows are not triggered in sequence. What means that you could be reseting your inputs before you create a new thing in your database, causing Bubble to create a thing with empty fields.

Can you try to remove the last part of your workflow and try again?

Hi! I’ve tried that and the result is the same :pensive:

This is odd… Can you share the link of your editor?

Hi @abby_hc , I had the same issue a couple weeks ago, as @rpetribu says, it’s a matter of order in the actions within workflows.

What I did is to create a custom event to trigger all the next actions, passing as parameter something that I didn’t use later calling to “Result of step 1” (dummy data), but to force the order of the actions.

Worked just fine after that

Hi @fmelion thanks for the help. I’ll try this out. Should I do this inside or outside of the reusable element? What’s bananas is that I get the same behavior even with JUST the “create thing” element in my workflow.

@rpetribu is there a way for me to share a link to the editor that would not make you set up an account? Otherwise Student Recruitment App The “add schools” feature is on the settings page which you should be redirected to or by clicking on upper right.


With all due respect to the previous replies, I have never seen such a simple workflow be affected by the order of operations, and I would have guessed it is not that (which you pretty much confirmed in your latest reply). If you go to the Settings >> General tab and set the Application rights to Everyone can view, we will be able to take a look under the hood to see if we can help. My guess is it has something to do with the reusable element, but it’s not really possible to know without being able to look at the editor.

1 Like

Thanks @mikeloc I made that change so let me know if you’re not able to view. I really appreciate the help. I hope it will not be a solution that is too embarrassingly obvious. :see_no_evil:

1 Like

I just tried to create a school, and it saved the school name, grade, and recruitment goal just fine (you can see it in your database). So, it seems to have worked for me.

It looks like you might have the popup on the page twice, though? Not sure what’s going on here.

Didn’t offend

Working for me as well. But I noticed you have made changes in your workflow

Yup, what @rpetribu said. Now you only have the create step in the workflow, and you said it doesn’t work for you, but you can see in your database that it worked for us. :man_shrugging:

Hi Mike,

That looks like a remnant of me converting the popup to a reusable element. I think the workflow on the school setup page (rather than the settings page) was still going to the original element rather than the reusable one. I think I’ve switched it to the reusable element and I’m getting the same behavior. Is this simply an issue of reusable elements + workflow that I’m missing?

I did notice in the schools that you and @rpetribu created that it did not attach the current user’s company, which is why they don’t show up in the table on either the school-setup or settings page. I have the create a thing set to company = current user’s company and the search on the table is looking for all schools where company = current user’s company …

Thank you both for troubleshooting this with me. I really, really appreciate it.

It didn’t attach the current user’s company because I wasn’t logged in as a user, so there was no company to attach. I (and I assume @rpetribu) just wanted to see if the create workflow is working, and as you can see, it worked for us. Without knowing exactly what you are doing and how it differs from what we did, I don’t know why it isn’t working for you.

Edit: I just created a school using the run as feature to log in as one of your users, and as you will see, it worked. So, again, I’m not sure what I am doing that you aren’t doing, but it’s working for me.

Hi @abby_hc !

Can you record what you are doing using Loom?

Video Message: Troubleshooting School Creation Issue (

The plot thickens! I only see the behavior when adding all the data to the form (address and grade).

Well, I just recreated the issue, and it does appear to be related to entering a value into the address field, but I have no idea why. Still poking around…

Edit: this is probably a stupid suggestion, but you might want to try deleting the address field and recreating it. That being said, I have never seen anything like this one, and it might be time to get Bubble support involved so they can troubleshoot it.

OMG recreating the address field… worked!!! @mikeloc you’re a genius.

1 Like

Ha! You never know when something like that is going to do the trick, so it never hurts to try. Stoked that it got sorted out!

Well. I think I found the error analizyng your log.
Bubble was preventing you to use Google API.
You was saving the Address field formatted as an Adress using Google API.

Now, you are formatting the Address as text. What does not use Google API.

That is why it is working now…


Ah, good stuff, @rpetribu. I wondered if it had something to do with the Google API, but I didn’t understand why it would create the thing and wipe out the values of all of the other fields.

1 Like