Forum Academy Marketplace Showcase Pricing Features

Thing being deleted automatically

Hi All,

I have an app where I create a thing called ‘Activity’ that consists of a number of items. I use a pop-up to populate this thing. Upon pressing “Save”, the worklfow is set to create an Activity, along with some other actions.

However, after it has been created and displayed, it seems to get wiped from the database and I can’t figure out why.

Cheers

Mark

Is it actually being created? As in can you see the entry in your database?

1st step I’d check your server logs, then second step I’d do the debugger in step by step mode to see exactly what WF’s are happening.

Yes. I see the data appear in the element for a second and then disappear

Which element?

Check the debugger/server logs to see if it is actually creating a new thing. I suspect that it’s not.

I’m using the Roadmap plugin.

I definitely see it appearing in the Roadmap for barely a second, but the data is there

I don’t know what the roadmap plugin is.

But you need to look at your server logs and debugger to confirm what is happening.

And have you checked your actual database to confirm the entry is not there?

There are blank entries there. Looking at the debugger it’s creating the data, but then when i go to the database, there is an entry, but it’s empty

So it appears no values are getting picked up from your inputs. Try taking out the reset relevant inputs step and see if that changes anything. It might need to be the last step in the workflow.

I’ve tried that, same issue. See GIF below:

You can see after saving the popup, it appears briefly and disappears

Have you got any privacy rules on the data type or conditionals on the repeating group data source?

And is it now adding the values to the database?

No privacy rules. It’s still not added values. As you can see before I do it:

After, it has a row, but it’s empty:

This topic was automatically closed after 70 days. New replies are no longer allowed.