Forum Academy Marketplace Showcase Pricing Features

Users are missing!

Hi all,

I have been building away happily for a couple of hours, and then all of a sudden, my app logs me out. When I tried to log back in again, it didn’t work… checked the server logs and it’s reporting that there’s no user with my email address. Weird.

Looking more in depth into my data, when I first uploaded the data into the User table, there were 3928 entries. Now there are only 2532! I have not deleted any users since uploading them, if anything I might have added a handful of test users.

I am really hoping this can be rectified (I have already logged a bug report). I’m not sure yet if there is any other data missing from my app. I can re-upload the user details but it’s a pain in the neck as I’ll then have to relink all the things connected to each user. I could wipe the lot and re-upload everything but then I will lose a month’s worth of data clean up that I’ve done post upload.

Any suggestions… or am i screwed?

Are you sure you didnt switch from dev to live version? If version-test is not in the url, you are in live version

Nope definitely not. I haven’t got any user data in my live version yet.

1 Like

There might be temporary issue. But I hope it will fix soon.

This just happened to me. I was looking at live and dev. Testing….

And then all of a sudden when testing against the live database, my user name could not login. When I didn’t get a pwd reset email I knew when I checked live production data that name was gone somehow.

Surprised I found ALL MY USERS were gone. Vanished along with everything linked to them.

I did not purge the user table manually (not a chance at a slip of the finger) yet somehow the user table was purged.

Is that name still in your development database? If so, then you need to copy the dev data to the live data.

Also, are you on a free plan? In Bubble free plan it restricts total records to 200 until you upgrade your plan.

Thanks for your input.

  • It happened to our live database. Our app is in beta atm.

  • We are on the pro plan.

  • The symptom - when I tried to login into our live app - I couldn’t get in.

  • The investigation - When I checked the live database, all my users were missing (plus their linked data) and there were 7 empty user records created (not there before) with no info but unique ids.

Hey there @peterdchamps,

I recommend filing a bug report at bubble.io/bug_report

yes, the issue has been submitted.

Omg… this is serious.

Please keep us updated about it

1 Like

I really hope you have privacy set correctly, and that your login was all backend without public API exposure.

The root cause was a code loop segment that we didn’t know was running that came with the template we purchased. When you went to a certain page in their template app and hung around for 5 mins it purged all the non-demo users which to us was our production user data. Bubble.io support was very responsive and helpful in tracking down the root cause.

1 Like

I’m curious – why did the template developer put this in there?

Because they’re not “developers” in the common sense of the word, perhaps?

They include that code since the reset loop allows you to run their template demo app and gather data (any user can test it out with some live demo data).

However it’s a demo app, so to limit the size and to deliver a good demo experience it purges any people “playing” in the demo app after an interval if you stay on a screen for an interval like 5 minutes.

We weren’t aware this code was in a workflow on that particular page since we hadn’t been in their template that deep yet to walk through it.

Lesson learned - user error, our mistake. It happens. Next time we will search any code we paste into an app for database activity that use loops.

Bubble.io support to track this issue down was superb.

Ah, got it. I thought this was a purchased template. But for a demo template, I can see why they’d do this, though they should make it explicitly clear.