Forum Academy Marketplace Showcase Pricing Features

Weird stuff with Ziggeo, or is it just me?

This one has got me scratching my head. Maybe someone can help…
I setup 3 Ziggeo Video Inputs. I setup a Workflow for each of them to Save a New Thing when the Video Input Value has Changed (instead of creating a separate button to save the recorded video, I wanted to save the processed video automatically). Everything was working great initially when testing in the computer browser. Then I started testing from an iPhone (browser), and that’s when things got a little goofy with the Ziggeo elements.

From the picture below, you can see that first video/workflow worked correctly… when I recorded a video it automatically saved the new video token to the DB and then I have a Video Player un-hiding (in the same spot) and an “X” icon (to delete the video record later) un-hiding when it recognizes that the Video Token hits the DB.

Now the second Video doesn’t behave the same way, it instead shows the “Re-Record” option, as if the Token and video details were not saved to the DB from the same workflow process that I followed from the first one (only changing the way I search for the video in the DB).

The only way I can get these to function properly again is to delete the second and third video inputs and video player elements and re-create them. Then everything functions as expected again for all three video inputs (without the re-record option, and automatically saving the Video Input details to the DB). Here’s the weird part, when I go to record a new video from an iPhone, that particular Video Input element goofs up again and enforces the Re-Record option. Again, the only way I can correct this, is to delete the second and third Video Inputs and Video Player elements and re-create them from scratch. Clicking Undo doesn’t help either.

This is driving me bonkers. Anyone got any tips? Or did I find a bug?

Hi I am Bane from Ziggeo, would be happy to help with your issue :slight_smile:

Looking at what you have mentioned, it seems that you have 3 different embeddings on the page shown at the same time (do correct me if I am wrong):

  1. when video recorded in first embedding gets recorded, you wait for the submitted event and then push the token to your DB.
  2. Once the token is added to the DB your code gets notified and shows the red x in the top right corner of the video

Now from what I believe to be the issue is that the x is not being shown on your second video, unless you recreate them (I presume through a console call)?

Now this question might seem silly, however I want to still ask it. Are you at any point changing the layout in which you are holding your iPhone? What I mean by that is, are you opening the page with iPhone being in Portrait mode and then switching to landscape during recording (for example) and then going back to portrait?

If you are, is it happening if you keep it in same layout the entire time?

Also, could you show us the code within “submitted” event?

Oh and, are you using Ziggeo plugin developed by Bubble.is team or are you adding it to your code directly?

Regards,
Bane

3 Likes

Hi Bane,
1 & 2 are correct.

Note: I’m using the Bubble.is plugin.

Now to answer your questions:

No, not quite… Once I run the second video, it doesn’t return the token on the second video… only shows the Re-record button. When I say that I’m re-creating it, I mean that I’m actually deleting the elements and starting over with the second video input and video player elements. I can get it to work again by deleting the elements that aren’t working and starting over. Originally after creating a new video input element, I’m using a computer browser to test, and it works as anticipated in the workflow (showing the red x after the token is received), when I switch to testing in mobile, depending on the orientation (like you were saying), the element then proceeds to have uncorrectable issues, requiring me to delete the elements again. It’s as if using the mobile browser creates irreparable damage to the element permanently. If I try the same with other known working Video Input elements, it will also corrupt them as well.

Yes, changing from portrait to landscape seems to be triggering the issue.

Yes, once this happens, it permanently corrupts the element. And is prevalent no matter which device I’m using… computer browser, iPhone or other device.

I don’t know what you are referring to in this question, I’m using the bubble.is ziggeo plugin.

The Ziggeo plugin by the Bubble.is team.

Thanks!

Hi,

I was afraid of that… Unfortunately this is not an issue on Ziggeo side, rather on Bubble side.

What happens is that when you change your layout during recording, all is OK, however if you - even for a slight moment - return to the page afterwards and are still in layout different to what you had when you started recording, the bug will come for your work and … change it.

The cause of why this happens is the Bubble’s rendering engine.

What happens each time you change the resolution (not needed to be mobile phone, you can do it with browser as well by changing its width for example from small to large) is that the code you have on page will be deleted (the one you see), then new layout is shown with the (new) code that you should have will be returned back.

Now when this happens our system can not do much as elements it was hooked into are now gone. It also means that the engine that did this added the code that was dynamically created by our system, so while it can work to some extent, it would never be the same thing (as it is no longer something our system can track).

As an example:

  • Our system picks the code like this:
    <ziggeo></ziggeo>

And renders it as:
`

` * There are attributes and other elements that are created, this is just to show a point.

Now when the engine does its job, it will not copy the original ziggeo code, rather the set of divs that was created and to our system these elements would not mean anything.

Not sure if you could raise this to Bubble team, however more people have such issue, more likely to be resolved since from what I know when we talked last they invested a lot of time and effort into their current rendering engine which otherwise works great, just for any code that hooks into elements on the page - it will break it.

Hope this helps.

Regards,
Bane

Hey Bane, I’m just replying due to you saying you’re from Ziggeo. I noticed that all of a sudden my Ziggeo videos aren’t showing. They were working as recently as a couple of days ago but even using the token as the Video ID doesn’t work. I can still record and all, just that the recorded video doesn’t appear.

Any thoughts? I’m wondering if this is connected to the main issue in this thread at all…

Hi @bane and @emmanuel , we have no problem recording and playing, the problem we face right now (Chrome console) is there is something with ‘load ressource’ and Editor Memory growing every minutes in size… At the end, the browser is very slow (including Bubble) and freeze eventually (too long to process I assumed). Any advice? There’s a new update (v2) release and add at the actual Bubble plugin?

UPDATE Dec 8, 2016: The issue is resolved. Thanks.


and another screen shot (if it can help)


Hi everyone,

I would suggest to either contact us directly at https://support.ziggeo.com or our support email: [email protected] if you suspect that the issue is on our side.

In regards to the issues above, I think that it is also best to separate them here as well. That would probably help others find solutions to their issues and would be easier for Bubble team to step in where needed.

@jjayma I will reply to you here: Ziggeo videos not showing and of course through the ticket you had made on our side

@JohnM I think that it might be best to open your own ticket here. It does seem like you had added Ziggeo resources 2 times, and the other errors are either around that or something else, however it would be best as said to open a new ticket here and we can check it out :slight_smile:

Regards,
Bane

1 Like

@emmanuel is there a workaround for the bubble rendering issue with Ziggeo when a user changes the resolution?