Forum Academy Marketplace Showcase Pricing Features

Zapier webhook Post To Bubble

I have a Zapier webhook set up to send a POST to my bubble endpoint. My database is set up to this handle this POST.

I need help as it is not working.

First, my ENDPOINT. It is expecting two keys: an id and a token. I am ignoring privacy rules and authentication. This didn’t work with authentication so I took it off thinking it will be simpler. Once I have this working, I’ll add privacy and authentication later. Here it is:

After taking in that POST data, I add that data to the users database here:

Now, let’s do Zapier. Here is the POST summary found in Zapier. Again, no authentication (yet) and we have the validic id and token in there.

I do the test POST in Zapier and get this:

Which means there is something wrong on my bubble end. Here:

Any ideas what my problem is?

Thanks in advance.

Yes, odd. I get that in POSTMAN (very useful for testing) as well. So it isn’t Zapier. It also fails on a GET of USER.

Firstly, it might be worth using the dev version of the API for now.

https://modernalkame.bubbleapps.io/version-test/api/1.0/wf/validic

See if you can remove the parameters (not sure about the spaces, but it may translate) and retry. Get it working on the most basic.

Authorised POSTs should work fine, so maybe try that with no parameters ?

Can’t see that what you are doing is much different to mine. Assume you are on a paid plan ?

Is you Bubble app attached to a domain?

1 Like

Great questions and comments! Regarding the domain issue: we do have the app attached to the domain but instead of “modernalkame.com” we have it as “app.modernalkame.com”.

So I tried out all 4 iterations on zapier.com and postman:

1:

http://app.modernalkame.com/api/1.0/wf/validic

postman returns:

{
“statusCode”: 404,
“body”: “{\n “status”:
“NOT_FOUND”,\n “message”: “Workflow not found validic”\n}”
}

zapier says:

Bargle. We hit an error creating a post. :frowning: Error:
app.modernalkame.com returned (404) Not Found
and said “{ “status”: “NOT_FOUND”,
“message”: “Workflow not found validic” }”

https://app.modernalkame.bubbleapps.io/api/1.0/wf/validic

postman could not get any response, not even a 404.

Zapier says:

Bargle. We hit an error creating a post. :frowning: Error:
hostname ‘app.modernalkame.bubbleapps.io
doesn’t match either of ‘*.bubble.is’, ‘bubble.is’

3

http://modernalkame.com/api/1.0/wf/validic

Postman gave a 404 and return the HTML of the whole page:
!DOCTYPE html>

<!--[if IE 7 ]>
<html class="ie ie7"

lang=“en”>
<![endif]–

Zapier says:

Bargle. We hit an error creating a post. :frowning: Error:
www.modernalkame.com returned (404) Not Found
and said nothing

4

https://modernalkame.bubbleapps.io/api/1.0/wf/validic

postman:

“statusCode”: 404,
“body”: “{\n “status”:
“NOT_FOUND”,\n “message”: “This application does not expose a
POST/Workflow API”\n}”
}

Zapier

Bargle. We hit an error creating a post. :frowning: Error:
modernalkame.bubbleapps.io returned (404) Not
Found and said “{ “status”: “NOT_FOUND”,
“message”: “This application does not expose a POST/Workflow
API” }”

Back to square zero.

I know app.modernalkame is up and running and we have the paid version of bubble and it’s attached to the domain. Very frustrating.

So your issue (a classic one) is that you haven’t deployed to live. Remember your app has 2 versions.

If you try in the browser
http://app.modernalkame.com/api/1.0/wf/validic
it says “not found”

but if you do
http://app.modernalkame.com/version-test/api/1.0/wf/validic
it says “Should be a post”. Which means it finds it.

Am I right? If you deploy to live that should work.

Ahh. I think I understand. But both links say “Should be a post”. So maybe I don’t understand.

In any event, I don’t want to deploy this so I should be using “version-test” regardless right now, correct?

Yes, exactly.

One more hump to go!

I get this now. Has anybody ever seen this before? As you see in my first post above, I have my endpoint well in hand. But apparently not.

You need to pass the parameters in the body, not the header. It is saying that Zapier hasn’t passed parameters.

(just some test data)

I would consider removing the spaces from the parameter, just to keep it simple.

The bad news … if I try to recreate I get …

This really should be a lot simpler than this :slight_smile:

Great tip on removing spaces! Getting closer. So I pass only the id in Zapier:

And I get back something I can totally work with:

Thinking I’m on to something, I pass only the token:

And awesomely enough, it spits back something I expected:

But when I pass both the id and token to bubble, it gives me the same 500 error you received. I’ve been working on this problem for hours and hours so I’m getting frustrated. I test it out using Postman, using both the id and token:

So it looks like a bubble issue and I pray, pray, pray that their technical difficulties get resolved soon.

Thanks again for your help!

Yes, something odd going on there, my Webhook workflows are OK, so needs investigating at the Bubble end. Ping them an email [email protected]

Fingers crossed :slightly_smiling:

The issue is that the workflow is trying to change the current user, which, when making an API call, isn’t set. We’ll fix that to not throw an error.
​In the meanwhile, let us know what you’re trying to achieve, and we’ll help design the right workflow for that.

Aha, that was causing the 500 ?

Yes. It’s now fixed. But not something the API is designed for. Let us know if you still need help here.

Although I guess you could pass the user back in and update it that way I lieu of “current user” ?

LOL, thank @AliFarahat. I was having this exact error message because I just copy&pasted the example URL without changing “appname” to my app’s actual name.

On a whim I tried to create an app called “appname” but it’s already taken :wink: