Forum Academy Marketplace Showcase Pricing Features

ZQ Fuzzy Search & Autocomplete stops working properly

Searching in ZQ Fuzzy Search & Autocomplete works fine at first and then stops working. When I make any small changes to the site and use the deploy currente verision to live, it works again and suddenly stops working again.
This was also happening with No Code Co’s Search & Autocomplete.
I thought switching to ZQ Fuzzy Search & Autocomplete would solve the problem, but it kept happening.
It is happening with all searches within my application.

This happens to me ever so often that i just gave up using it.

Hello @contato52, @ihsanzainal84
Thank you for reaching out. :pray:t2:

Unfortunately, the issue you have described is not reproducing on our side. Can you please share with us the maximum details that can help us reproduce the case - a video record or a step-by-step flow of the issue reproducing with the plugin settings screenshot and explanation of your use case.

Hope to hear from you soon.

Best regards,
Zeroqode Support Team

Could this be overloaded servers dumping your search requests?

I have experienced rather unpredictable results from the database over the recent weeks.

As far as I have seen, bubble gives no indication when they terminate your workflows. I was running backend loops to import data in batches, say roughly 500 at a time. Some would run through. Some would stop any random number, 205, 167, whatever. It appeared that bubble occasionally just kicked out the loop when it felt like it. I reproduced this scenario countless times, not an isolated situation.

My top concern is there is no indication of when this occurs or why this is happening.

Subbing thread as I also had considered this plugin.

Hi @insightrade,
Thanks for your message.

Allow us to suggest you submit the bug report to Bubble. 500 data at once should not affect this, therefore it is better to double-check with the Bubble support team by submitting a bug report.

In case we can help you with anything else, please let us know. :pray:t2:

Best regards,
Zeroqode Support Team

1 Like

I have discussed this matter with them and was given great support in the process. The only part I want to zoom in on is reporting - I know roughly what is happening by looking at the results of the process (after the fact) but there is no where I can find or figure out yet in the application to expose that information. I am learning more about the log features. Perhaps I have not yet found the place to drill into for this, thus I was reading further into the docs first before posting more about that.

Also this performance is in relation to run workflow on a list. If I use the method of creating an integer to iterate through the recordset and call them scheduling an API recursively. To me I preferred loading it by list as that makes more sense than the recursive method. I find in that in the recursive loop method, I am repeating similar database queries & the structure seemed less efficient. These start much faster. However, just the general programming logic to me seems so shaky, one mistake with your do while condition and you have an infinite loop. Certain that is known and also why there seems to be a limiter on that which kills long running processes.

Thank you for your response.

@insightrade , thank you for sharing your experience with the community. :pray:

In case if there is anything we can try to do to help you with our plugin - feel free to reach us out.

Regards,
Zeroqode Support Team

Tks for your replay. :slight_smile:

This video shows the problem:

The database just have in type “Contato”, the one where the search is run, only 377 records.

In this video with a example, the plugin worked in the development/test version and did not work in the live version.
However, this has been indistinct. It also doesn’t work in the trial version many times. Some time works, some time doesn’t. Regardless of the live or development version.

Hello @contato52,
Thank you for the video. :slightly_smiling_face:

As we can see from the screencast, you are setting the Repeating group Data Source - the reference to the plugin’s Search Matches and we need to point out that this is not the best way. If you check the plugin demo page, you will see that the Repeating group Data Source = the database table on which you are doing your search. It means you should indicate the Do a search for database table name as a Data Source of your Repeating group. (Screenshot by Lightshot) In your case it’s Contato. So, please try to change the Data Source of your RG and give it a try.

In case the issue still persists, would it be convenient for you to share access to your app so we can take a look? For this please add our [email protected] email as a collaborator of your app (disregard the warning, our email can be added to the collaborator list even if your app is on the Free plan).

Looking forward to your reply.

Best regards,
Zeroqode Support Team

Thank you very much for your reply.
I saw your example on the plugin page and made the change in the same way as it was there.
I changed the repeating group search source to “Contato” and put the condition to change search source when Search & Autocorret Plugin result count was > 0, like is in your exemple plugin page.
It worked at first and then stopped working again.
I added your email [email protected] as a contributor to the application.
Thanks for checking out what might be going on.

The page is “contato_cadastrado”.
There’s the plugin in several other places. Fixing this one, I can understand and fix the others.

Hello @contato52,
Thank you for providing access. :pray:t2:

Indeed, it’s strange behavior as the issue is not reproducing on our demo page. We’ve passed this issue on to our developer team. Let us check what might be the issue, as soon as the investigation is completed, we’ll get back to you.

Best regards,
Zeroqode Support Team

Tks for your answer, commitment to the solution and quick response.
The competence and seriousness of Zero Code are evident here.
:pray:t3:

1 Like

Hi! Did you manage to check what is happening with the plugin?

I need to put the APP into production for other users to proceed with the validation phase it is currently in and I will need to remove the ZQ Fuzzy Search & Autocomplete from the pages where it is in production and use only the highly limited search of the SearchBox native tool , from Bubble itself.

For you to continue the study you started, I saw that you duplicated the original page where the plugin was installed on a page named “zq_test”. Thank you for continuing the research and finding the solution there.

There is a plugin similar to ZQ Fuzzy Search & Autocomplete, Fuse Search, on whose page (Bubble-essential-plugins | Bubble Editor) there is the following explanation:

“ATTENTION: Unfortunately, because it is an action plugin (Client-side), it is impossible to use this in a database with more than 500 items. You will experience a drop in performance and crashes.
It works perfectly in databases with up to 150 items.”

:point_up_2:t3: Although I myself don’t have enough technical knowledge to understand why this occurs, I ask: could this be the same case with ZQ Fuzzy Search & Autocomplete Plugin?

I suppose thousands of applications around the world need to search databases with thousands of records. I imagined that for this need there were many efficient solutions available, technically easy to develop. However, unfortunately, for use in Bubble, I’ve been searching intensively for over a month now, and so far I haven’t found anything that works.

I hope Zero Code gets a solution soon for this problem as it is for sure a solution that will solve the pain of thousands of Bubble developers.

Gratitude for your effort.

Hello, @contato52.
Apologies for the late reply :pray:

We are still working on it (during working hours). Apologies, there’s quite a workload on our developers that affect the time for delivering investigation results. We will do our best to get back to you asap on Monday.

There might be a such possibility since the free Fuzzy Search plugin works super fast in databases with a small amount of data. To be clear, let us please discuss this question with the plugin developers.

Thank you for your understanding:pray:
Regards,
Zeroqode Support Team

Hello @contato52,
Thank you so much for your patience. :pray:t2:

We have finished the investigation of your use case and the issue was that the input element which you are using to search was loaded before than Search&Autocorrect (plugin element). Therefore, we’ve added the “show Search&Autocorrect” action on page load and everything seems fine now. :slightly_smiling_face:

Summary

We’ve created a test page (zq_test) in your app. Please check it on your end, simply add the same action to your page and let us know how it’s going.

Best regards,
Zeroqode Support Team

Hi!
I followed the procedure and put the “show Search&Autocorrect” action on page load, but the problem continued to occur in the same way.

Is there still something to be done?

Hi! @contato52,

We’ve checked your page once again and here are the things we’ve done:

  1. Deleted the plugin element and placed a new one
  2. Disabled the “This element is visible on page load” field for the plugin element
  3. Placed the repeating group in a group with data type “contato”

After these changes, the search was made successfully on your page. Please give it another try and let us know if it works on your end as well. :pray:t2:

Looking forward to your reply. :slightly_smiling_face:

Best regards,
Zeroqode Support Team