Autobinding stoped working

Hi all.

I have an issue with setting up autobinding.

The user should be able to edit his project’s profile page (i.e. upload cover picture and choose location).

There is a user datatype and project datatype applied to this page. I can’t find out where the issue is happening so the autobinding is not working.
Maybe the problem is within Privacy rules? I’ve tried to change them, but still no result…

Please see attached screenshots.

Thank you

Is the Parent element’s thing empty? That would mean you’re auto binding to nothing.

You can use the step by step debugger to check

Thanks for the advice. I’ve tried to choose a country and it seems that there is a empty field (Option caption) in the debugger. I’m not quite sure if this is a bug or not. Haven’t user the debugger before:)

Yeah that’s probably a bug, but it’s not affecting your issue.

Hover over the parent element (the group that contains the Dropdown). What’s the data source of that element? If it’s empty, that’s your problem.

I have a User type of content for the page and after it switches to the Project type and all the way down to the very small group including this dropdown is set as a Parent’s group project.

Have you verified this using the debugger?

1 Like

Looks like the data source is not empty…

Click on Parent Group’s project.

I have an idea, that maybe this issue is because when user signs up – it appears in the User data type base, but the Project data type base stays empty. I thing I have to set the workflow so when user sign’s up the new related project data base cell also is being added as a related on to current user… Does it make any sense? :sweat_smile:

On the screenshot the new signed up user is Vladimir

But there is no related cell in the Project data base

You need to pass the Project data through all of the groups if you’re using Parent group’s X, there’s nothing else to it. Make the Parent group not empty and your autobind will work.

I’m stuck… Can’t figure out why 's Project is still empty. All groups are set to the same type of project. I’m missing something, but can’t understand what exactly😅
I really appreciate your help. I’m gonna take some time and try to fix this problem haha

You can see from your database screenshots that Vladimir’s project is empty.

Create a project, and make changes to Current user so that Project = Result of step X (Create a new Project).

Wow! Yes! Now it works! Thanks a lot:)))))))