Critical bug - saving entries not attaching data type object

I’ve yet to submit a proper bug report, please can someone confirm they are experiencing the same issue?

It appears editing an entry that has a single related data type object won’t save. Please see below demo. In the list view it appears the field is linked, but then editing the entry the field is empty and when trying to assign its missing upon save…


p.s. this is in development version

Just tested this on another application on a different account and same issue persists @eve

Confirmed bug reported: #8254

I’ve been having a few issues with data integrity lately. One is that on saving items to a list, the items are getting removed randomly, so will initially save 11 and then it changes to 4 without any other workflows that might interfere.

I also was adding entries for time slots using a button to add each entry and so was watching closely and noticed entries getting changed or deleted just after creation.

Bug report received and confirmed; our team is on this now. Thanks for reporting!

When you open an item in the App Data view, some fields are not displayed, such as unique id, Created date and Modified date.

The unique ID issue has also been reported and is currently being worked on.

Hi @eve

This is still not resolved for me - tested on a few apps and same issues. Tried clearing cache and logging out…


The issue is with our engineering team for investigation; in the meantime, it does look like the fields are linking correctly (I’ve confirmed this in a test app with a variety of searches) and the only thing impacted is the Edit window. Our team will continue working on this.

The unique ID issue should be resolved.


Thanks for the reply. Unfortunately though the issue is still not fixed with regards to this post thread bug.

I was expecting a hot fix by the end of the business day to be honest. Have to say I’m quite disappointed a bug like this could be present and not quickly patched. I guess it will be on hold until Monday to resolve. Please keep us posted.

1 Like

Credit to @Taiheta
Objects will now still save and remain when editing an entry with a attached data object, but wont be visible in the edit window. So currently this is now just cosmetic but worth noting when making direct changes in the editor.

1 Like

I’m experiencing the same thing. Bubble DB editor shows fields as empty, but in the app, the correct info shows up.

If I change the Search field in the DB editor to unique ID, it suddenly shows up again.


Also sent a bug report yesterday with an example.

1 Like

I’m seeing the same issue on my end as of friday.

1 Like

Same issue here. Hopefully find a fix soon

This still seems to be an issue @eve - please can you update us on a fix

Hi @luke2,

I sent a bug report two days ago.
Can you tell me if your fields have special characters like

_ or . or :orange_square: anything special?

I suspect that might be the cause.

Hey @JohnMark

Same here, bug report sent last week.

On some apps yes, but others I’m not, just normal text used on data type name e.g. no emojis. Are you experiencing the same issue?

1 Like

Just tested and this appears to now be fixed.

This topic was automatically closed after 14 days. New replies are no longer allowed.