Data type search not working

I have two data sets and one is working as expected but the other isn’t.

Data type A works as expected in the app data tab: I can search for things and edit them. I can look up data type A items when editing an item in data type B, which is what I wanted so I can connect them.

Unfortunately, data type B’s search function doesn’t work in the app tab nor does it work when I try to search from an item in data type A.

Here’s what I’ve looked into so far:

  1. I have this problem in both my live and dev environments.
  2. Both data types have the privacy set to public.
  3. The item I’m searching for in data type B is indeed in the database, both dev and live (it just appears not to be because the search comes back empty)

Hi there, @nico2023… because you mentioned the App data tab, I wonder if the issue you are describing is related to B’s primary field being set to the unique id while you are trying to search for something else. Have you clicked on the Primary fields button in the upper left of the tab to see what the primary field is for B?

Best…
Mike

Ooh, this is definitely helping narrow down the issue. I had it set to the correct primary field, but that’s a lookup for data type A. I experimented and switched it to a non-lookup field and the search function worked as expected. So that’s the issue, but I’m not sure why it’s a problem
(maybe a bug?)

Sorry, but I don’t understand what you’re saying, but I’m guessing it’s not a bug. Some screenshots would help… or maybe that’s not necessary because it sounds like it’s working for you now.

Sure, let me clarify with some visuals since it’s still not working. To recap: what I want to be able to do is associate two data types with each other.

Here are my data type primary fields are set up:

And how fields are set up for data type B (showing that data type A is a field):

When I have data type B’s primary field set to “Name 1,” a regular text field on the data type, search works as expected:

When I change the data type B primary field to look up items in data type A, it fails:

Proof that the item I expect to be returned is indeed in the database:

Basically what seems to be happening is that if I try to search one database with a lookup field for an associated database, it fails. Maybe this is because it’s a “double search” so I must search on a non-lookup field.

Oh, yeah… that search doesn’t work… never has. What are you trying to accomplish by doing that search? Can’t you put a repeating group somewhere and get the items you want?

I need to associate two data types and in both cases, the brand name (data type A) is the easiest way to find what I need. It’s a simple enough workaround that I just added a redundant text field for that. Annoying, but ultimately just an inconvenience.

1 Like