Forum Academy Marketplace Showcase Pricing Features

Debug mode not showing in Preview

Hello!

I am not seeing the debugger at the bottom of my preview page, even though the url says “debugmode=true” at the end…
Any idea why?

Regards,
Jennifer

1 Like

You have to be logged in with Bubble for security reasons.

I am!

Also, where is debugmode coming from? it’s been debug_mode=true from the beginning.

Sorry for my approximate message. It’s debug_mode=true indeed and not debugmode.

The fact of the matter is: I cannot get the debug mode to work, even though I am logged in, making my app. I really want to use it to fix a couple of things. Any idea why I can’t get it to work?

Have you tried the usual stuff yet?
Close the browser, clear the cache and cookies, restart the browser
Check the console for tell tale errors etc.

Hi DaveA,

I did the cache and cookies thing, and don’t see anything particular in the console but not sure what I’m looking for.

The console does say:
warning: no id specified. this page expects an id

Is this the issue? I am signed in to Bubble though, so why is it saying this?

Did you manually create the link or did you click the preview button from the developer environment? TRy the button from the dev environment to make sure.

I have made the mistake when manually typing it of putting ? instead of & and then it stays in the link history…

That’s normal…

Always used the button…

Reboot the computer?
Have you tried another browser?
Get some beer…

I’m on Chrome. It does the same on Explorer.
Also, same on a new app I started just for testing it.

Beer also did not fix it… it almost screwed up my computer though…
Any other solution?

Are you using custom domain, does the address bar look normal, does it do it on all apps or just 1.

Try this link to my demo app: https://dave-auld-demo-stuff.bubbleapps.io/version-test?debug_mode=true

it’s on on this link! first time I see how the debug mode looks like!

So it works with that, is that what you are saying?

yes that’s what I’m saying. But as soon as I’m back on my app, it doesnt.

Can you share a link to your app to see (app set to public, or read only), I can see if it does the same on mine…

https://bubble.io/site/nexteps/version-test/

Looks like you have an on page load event that is redirecting and stripping the debug_mode parameter.

The link above just takes your nexteps.bubbleapps.io/version-test, if I add the debug flag, it simply redirects to nexteps.bubbleapps.io/version-test