Debugger is missing?

Hi there,

I’m new(ish) to bubble and trying to get the debugger to show in my preview. The instructions in the bubble manual show this behavior, which I am NOT able to reproduce on my end:

I’ve tried some of the suggestions from this thread below that speaks about another user’s attempt to resolve the same issue, but the suggestions did not work for me and I am still having trouble:

I have tried:

  • Disabling Adblock
  • Tried different browser (both Safari and Chrome for Mac OS)
  • Made sure I was logged into bubble while attempting this (plus various permutations of making sure I was logged into and out of each browser)
  • Pasted debug_mode=true parameter into the URL

Here is a gif of what I’m experiencing:

Looks to me like the debugger is showing up fine on your browser.

As an example, if you click the “step-by’step” button (it’s now highlighted orange) and then run your app, you should see any workflow you created and you can click through one at a time.

In “normal” mode (normal button is orange), it will just run through and will only show something if there is an actual workflow error that stops it from moving forward.

Hope that helps,

P.S. Your test app url should always look like this (and it happens automatically when you use “preview” from development side:

Thanks for your help and verifying there was nothing wrong with my testing and configuration.

I read and re-read your response and was in the process of writing a long response about the details of my URL, etc, when I discovered my mistake. I was, in fact, not executing any action at all when clicking this button (and therefore the debugger wasn’t showing).

Turns out I had missing data in a required field and the button was actually not clickable. In a more typical UI it would be ‘greyed out’. Due to my lack of understanding in the UI style options I had created for this app, I didn’t realize that I was attempting to click a non-clickable object.

Additional confusion was that I was feeding a parameter (email address) into the PLACEHOLDER of a required field, not its value. Seeing this made me think the value was inside the field, when it reality, it wasn’t and so I wasn’t able to click submit.

Confusing UI was confusing and I was clicking a disabled button :-p

Thanks for posting back. Such things happen when you’re learning the ropes. :slight_smile:

As well, one of the great features in Bubble to dig deeper is “Element inspector” tool. When you click on the icon, you can see workflows, etc that are directly driven by that button and tangentially related to it.

P.S. If that is your design for the calculator in the screenshot, wanted to say very well done!

Hey Dan!

Thanks for the tip! I was actually following along through Salar Ali’s udemy class Build Your Startup with No Coding that was in a list of learning materials you had recommended to me via our conversation on sixty last week.

BTW, I’ve been involved in my startup for over a year now and the consultation time I purchased with you was easily one of the best decisions I’ve made. I’m plugging along with learning the platform and I’m looking forward to continuing to work with you again once I have a better foundation. Thanks again!

Thanks Jon, I appreciate it!

This topic was automatically closed after 70 days. New replies are no longer allowed.