Disabling submission of text input when Enter is hit

Currently, it seems that whenever one hits Enter while typing inside an Input form, the content gets submitted via the action associated with a nearby (?) button.

It is possible to turn off sending when Enter is pressed? Many of our users find that otherwise useful feature irritating because they tend to submit multiple sentences in a certain input form.

Thanks.

The action “Enter” seems to vary between a standard input and the “Multi Line” input. In Multi Line input, enter gives you a new line in the box, and doesn’t do the “nearby button” action.

Maybe change the input to Multi Line ?

1 Like

That’s the right approach indeed.

Great. Thanks Nigel / Emmanuel.

1 Like

Is this still an issue? Hitting ENTER always returns the value of the Input, so we need to change every input box to a single line “mulitline input box”? There’s no way to disable an Input??

also, I would like to be able to switch this function on for multilineinputs. Would it be possible to put that on “the list”?

1 Like

We can’t do this, multiline inputs take enter to go to the next line.

sorry need to be more specific:

I was thinking about something like in facebook:

Where you have to press Shift + Enter to get a new line or press only enter and it sends the data. Or you can deactivate it and need to press the button to send.

Would that be something achievable?

1 Like

What we could do is add an option “Trigger a workflow when the user presses SHIFT + Enter”. would that do it?

1 Like

Hi,
Is there a way to remove the action triggered by pressing Enter for single line input?

1 Like

No there isn’t, but in general it’s a better UX that way. What is the situation?

A hack is to have 2 workflows that could run using this input, in that case, none will be run.

How can I set up such an worflow? So when SHIFT+Enter is pressed the multi-line input is submitted?

hello everyone!

I’m building a simple chat using a regular input. I’m ok with Bubble sending the chat message when I hit Enter on my keyboard. My issue is that for some reason, when I hit Enter, the page scrolls down quite a bit, which is very annoying for UX.

There is no workflow to change the scroll position on my page.

I know I could use the multiline input instead and have this issue go away, but I prefer the regular input unless I have no other option.

@AlonsoC Have you tried using the “Scroll to” element action? You can add it to the same workflow and choose the Enter button as your element to scroll to so that it stays there… or wherever you’d like the page to be.

Thank you Gaby for your useful suggestion! It´s weird that it´s scrolling on it its own by default so I´ll have to use a “scroll to element” workflow to counteract that behavior.