Domain not working

Hi guys when i went to look at my website this came up and I’m not sure what to do or what it means

It also said in the editor that my dns record were not correct so i went to my domain provider and managed to sort out the dns records but still not working.

Not sure what has cased this or how to fix it.

Please help!!

In my experience, sometimes when DNS records change (not Bubble), it can be helpful to delete the settings you have in Bubble and re-enter them. The other possibility is that DNS records can take 24-48 hours to populate around the world - which is indeed a long time to hold one’s breath and hope it works!

I built this website and lunched it like a week ago so i had all the DNS settings set up but why have they changed on their own is what I’m wondering.

The other thing is its only doing this on my pc if i go to the website on my phone it is live and working fine just on my pc its not working and has this error message.

Have you tried loading in an incognito window, and/or clearing your browser’s cache (or using another browser?) It also couldn’t hurt to look at your computer’s own DNS settings to make sure there’s not a conflict there.

yes i have had a look at my browsers cache but how do i look at the computers dns settings?

On a Windows machine, this walks you through it:

(and 1.1.1.1 is Cloudflare’s native DNS if you wanted to use that)

On a Mac, the DNS settings are here:
Change DNS settings on Mac - Apple Support)