Error: SSL Version Interference?

I have been getting a strange ephemeral message on my live site the last two days. Hoping someone on the @Bubble team can respond. Just before page load, I see this browser error, which lasts for about a half second and then proceeds to load the page normally:

It doesn’t happen on every page load, but it seems to be a persisting issue the last two days. I can’t imagine anything I’ve done over the last two days could have caused this directly. Any ideas? Is anyone else seeing anything like this on their app?



It will become an official bug report soon. I sent one this morning to @neerja.
You are not alone. I think @Mischelle have that too.

I tried to remove some plugins, with no good result. I removed all Chrome plugins too. It’s sound more an “elastic” thing from Bubble. I tried on another system around this world to be sure, same result.

Thanks for the additional info, @JohnMark, and for taking the time to log the bug so that this gets attention.

1 Like

I submitted a bug report today, too. I have the same errors as you, plus I don’t have server logs, and my SSL went down for a while.

Does Bubble support not fix bigger issues like this on the weekends?

1 Like

I saw some expiration date on Bubble ssl, maybe that.

Any issue like this that impacts production apps will get fast attention, weekend or not, but like any software company they need to first learn about it, reproduce it, diagnose it, resolve it, then push it, which can take some time. I’d like to see some alert or acknowledgment, though. It’s a very bad “bug”, whatever it is, since it is seen by everyone who uses our apps and looks scary to a layperson.

Hi @edd,

I was getting constant down alerts from my monitoring providers Pingdom and Freshping, that my system was going down about every 30 minutes.

The reports from them were something to do with the SSL, they were simply saying SSL Error.

I checked the expiry of the SSL and it says 4th Mar to 2 Jun 19. So they are current.

@Kfawcett suggested it may be CloudFlare. There are some plugins that use CloudFlare.

I removed the SSL from the monitoring alerts as I was getting over 60 a day and it was like cry wolf, I didn’t know if my system was actually down. I will get this investigated at my end, as well as report a bug.

We’re looking into this

1 Like

We’ve been able to reproduce the problem. Not sure how many apps it affects yet, might be just the people on this thread. We have a couple hypotheses about what’s causing it – I’m deploying a fix for one of them to see if that resolves it.

Okay, fix is live. I haven’t been able to reproduce the problem since the fix went live – that’s not hard evidence we got it, since the issue was intermittent, but it seems likely we did. I’ll keep monitoring, and post back to this thread if you are still seeing this error.

1 Like

It works for me, many thanks.

So far, so good. Will post if I see it again. Thanks, @josh, @neerja, and others here.

Actually, @josh, can you explain more what the cause may have been, and the remedy? I’m specifically wondering if there was any kind of clash between /version-test and live? I had some strange user reports Tuesday-Thursday that people have found their way onto my /version-test site and I cannot figure out how they’ve managed to do that.

Chrome made some changes to the way their TLS implementation works that caused some issues with node.js; I upgraded node to the latest version, which had a fix. So likely unrelated to your users ending up on the test version


I was seeing this issue too intermittently couple days ago. Seems to be okay now.

I am experiencing same issue with my new app. I get ERR_CONNECTION_CLOSED & SSL_VERSION_INTERFERENCE errors. I just sent an email to support.

Hello @josh and @neerja,

since yesterday I’m experiencing this constantly on my live app. I’ve started receiving complaints from customers.

Is there any clarity in what the underlying issue is? Is there anything I can do one my side?


@berlin_based 2 things to check:

Thanks for the quick response!

@neerja I don’t use Cloudflare.

I ran the test (, Besides DNS CAA it looks good.

The thing is that the error doesn’t occur on every single page load, only some, so I believe that probably the SSL Certificat isn’t loading properly everytime.

I’m having the same issue @berlin_based is having.

It seems many issues have been showing up lately on bubble. Many of ours customers are complaining about odd behaviors that shouldn’t be happening and we couldn’t understand why they are happening.

@neerja please inform us regarding the issue.