List of things- export/import

Having trouble getting the list of things into the right format so it uploads.

What I’m doing:
Example data (list of things, category):
apples ; bananas, fruit,
carrots ; salat, vegetables,

Problem:
When I try to validate the data I get this message
“There was an error analyzing your data Adam ; Eva is not recognized as a list. It should be written as [fxx,yy].”

Any suggestions?

Can you copy paste what you’re uploading (at least a sample)?

you should write

Adam ; Eva, human

shouldn’t you?

Is this the CSV upload ?

And you are trying to import into a list of … ?

Well, it has me stumped.

If you want to upload a list of texts …

What do you put in the field ?

I downloaded CSV and then I’m trying to upload it back up again. Only changed the delimiter for the list to “;”.

HERE is the data:
“list_emails”,“name_text”,“Created Date”,“Modified Date”,“Created By”
"martin@gmail.com ; michal@gmail.com",“veronika”,“Jan 25, 2016 7:02 pm”,“Jan 25, 2016 7:03 pm”,""
"martin@gmail.com ; michal@gmail.com",“caitlin”,“Jan 25, 2016 7:01 pm”,“Jan 25, 2016 7:03 pm”,""
"martin@gmail.com",“jose”,“Jan 25, 2016 7:03 pm”,“Jan 25, 2016 7:03 pm”,""
"martin@gmail.com",“michal”,“Jan 25, 2016 7:02 pm”,“Jan 25, 2016 7:03 pm”,""

Same error:
“There was an error analyzing your data martin@gmail.com ; michal@gmail.com is not recognized as a list. It should be written as [fxx,yy]. Please check: this is the entry number 0.”

Yes to both of your questions.

Yeah, I don’t see how it works either. I did the same by downloading a list and re-uploading.

Maybe email @emmanuel at the support email ?

Are you sure you picked the right separator for the list? Also, it should be between [ and ].

I tried out all separators but non work. What do you mean by: [ and ]?

What I do just to try it out:

  1. Export CSV.
  2. Delete all entries.
  3. Upload CSV.
  4. Pick a file to upload into the same “type of data” and data delimiter is set at “,”
  5. Map fields. Select “List_email” then select User_emails and separator “,” (I tried ;, |, tab)
    Name=name
  6. Validate data.

Then I either get the message above or it says that I have too many or too few entries in some lines.

Name, testlist
Bob, [“a” ; “b” ; “c”]

Hey guys,

Thanks for reporting and helping. We are looking into this and also adding a bit more info on how to use the uploader. We’ll repost when we have an update.

2 Likes

Any update?

I am exporting from a 3’rd party database with users, but the output CSV doesn’t enclose user roles in brackets (ex. “[admin, editor, viewer]”), it just separates them with a comma : “admin, editor, view”. So when I go to upload that CSV into bubble, the error about brackets keeps coming into. I don’t have time to enclose all 2,000 cells in brackets manually. Any idea?

We don’t support this. I would recommend writing a script and upload te data with the post API if you can.

1 Like

@emmanuel
As I’m sure you know, CSV is a very common way to move data around, and it would seem to make sense to adjust Bubble to recognize the csv data without the brackets, rather than asking people to write scripts, which seems counter to Bubble’s core purpose of not needing to code.

Is there any way this can be fixed?

Here is the easiest way I know how to work around this problem. I use Excel, but this should work in Google Sheets as well.

  1. Open CSV in Excel

  2. insert a new column (ex. B) next to the column (ex. A) of comma separated data you need to fix

  3. in the first cell (ex. B2), enter the following formula ="["&A2&"]"

  4. copy this formula down by double clicking on the “plus” symbol which displays on hover of the bottom right corner of the selected cell (ex. B2)

  5. Save (in Excel, when saving as a CSV, it will convert formula to text. when you close and reopen the file, it will be text. Then you can delete the unbracketed column if you want)

5a) alternatively, you can insert another new column, and copy the entire column of data with the formula, and paste as text values only

  1. Note: if some of your cells are empty, you’ll end up with [] which Bubble won’t like. Solution to this would be to create an If/Then formula so no brackets are added if the cell is empty.
    Example: =IF(A2="","","["&A2&"]")