Forum Academy Marketplace Showcase Pricing Features

List within API connector

Hi -
I have a list that is returned as one of the elements in an API call. For instance:

data.thisdata=(list)[item 1,item2,item3]

The list isn’t displaying anywhere on the page, and I can access just the data element in question to turn it into a list that would be recognized by Bubble (e.g. the “Main List” dropdown does let me select ‘data.thisdata’).

Is this supported?

I have the same question.

P

Arrays are supported. Would need a bit for detail to know what is happening.

Hi nigel - I’ll see if I can provide some over the weekend.

Best,
P

Hi Nigel - thanks for jumping in.

In the API plugin, I get the results for my API call here:

The only main list I can select is “links”. But what I want is to select a list using data.amenities so that I can use this list:

Since I can’t tell the code to identify this list, it doesn’t display information. Any other field does display, provided it isn’t part of its own array.

Am I missing something obvious?

Ah, I see.

No, ordered lists of values don’t work in that way. Bubble only like lists of objects (so name : value pairs) it seems.

As it happens I was trying this yesterday …

It is a list of tags. And I can’t even get Bubble to bring it back as a string of text.

Maybe one to ask @emmanuel

I’m having this same issue. I actually thought it worked briefly, but lately it hasn’t been working at all. I’ve passed the contents of the list to a repeating group. I then put a textbox inside the repeating group and pass it the current cells text. But I get nothing when I run it.

1 Like

Agreed, I can’t get it to display and have tried multiple ways.

I’ve been struggling with the same recently.
Thought it was just user error from my side, but hey!

I guess it’s nice to see others with the same issue @emmanuel do you have any thoughts? For what it’s worth, I’m pretty sure the list was working previously, but wasn’t being treated as a list - it was instead just displaying all the items within the list. Although that wasn’t perfect, it was better than nothing.

Did any one manage to get this to work?

I created a test app, to see if I can get it to work. The API seems to see the data fine:

Not sure how to set up the Datasource to recognise as list:

I have the example app here, if any one cares to have go:

You can change the RG type to text and read it as a list of texts… ? See RG below yours in the example.

1 Like