My dropdown menu don't display any choices actually it refuses to expand at all

I am trying to use a dropdown and the data will be from an option set I set up the option sets
and configured the dropdown menu as usual but when I click on it shows me a thin black rectangular box instead of the option set choices

the solutions I tried and failed
1-I tried using static options and I got the same result
2-i tried adding a default value to the dropdown menu
3-i tried deleting elements below the dropdown menu to allow it to expand fully but it didn’t make any difference
guys, it has been 3 days and I haven’t figured this out yet I feel like I am about to lose my mind
notes: the popup is a reusable element and I am using a prebuilt template
i also got another question how can you guys fake deleting data it will not actually be deleted from the app database, but rather removed or hidden from the site so it’s not
accessible by users. This approach prevents orphans, or disconnected and
unreachable data from being created when a task is deleted.
if anyone can help me with these two problems I would be glad

You are currently using fixed layout settings and an older version of responsiveness, which might be causing the issue. I would recommend making your page responsive to resolve this.
Just add a new empty page and make it responsive and add your dropdown there, and check the result.

1 Like

They’re using a template, etc. To pass items to the pull-down, which is in a reusable, they will have to take advantage of this knowledge:

1 Like

i tried clicking on the upgrade to responsive button on the upper left and i got this message

and now i am a bit concerned this will ruin the app template or may be cause any malfunction that i can’t fix
and if i did this will it change only this reusable element or the entire app ?


This topic was automatically closed after 70 days. New replies are no longer allowed.