[New Feature] Geographic search box improvements


Last update for the day :slight_smile: We added some improvements to the Search Box element when used to find addresses. You can now define a location and a radius (in meter) to search around, which will help narrowing down the list of items that should be shown to users for more relevant results.

These settings are optional, if you don’t set a location it will behave like before.


What a day! :slight_smile:

This is great!


I was impatient to see my orange-Gift icon this month, thanks. :grinning:

1 Like

That is cool!!! all though the orange gift icon is not showing in my app. uhh oh. does that mean im not getting gifts :frowning:

The change was made a few days ago I think ?

Thank you, thank you, thank you. I’m looking forward to implementing this soon!

1 Like

oh i must have missed it… i get so excited over that icon… more so then is healthy i think :slight_smile:


This is really nice. Thanks! Is there a way to use this same search input to display and choose groupings of data? That would be fantastic. :slight_smile:

@emmanuel - when using my own API keys, it is not returning any results. Any insights? Others encountering the same issue?

For background.

  • I’ve tested multiple keys in multiple apps and in safe mode.
  • The associated keys have all Maps APIs enabled.
  • Have tested using Bubble v4 and v5.
  • Results are properly returned when I do not provide an API key (using Bubble’s defaults).

You should make sure the API console has Google Places activated (on Google’s end)

@emmanuel - correct, I have Google Places enabled.

My Google console is showing new requests under Places API for Web when I use other maps-related components. (If you have an API key I can test against, happy to do so). Let me know if you’d like a bug report.

Cool and thanks!

I have created a topic about that in bug sections and have been in talk about this issue since two weeks now…

Hi @dan1 … I have the same situation as you and the same thing is happening to me. Try adding “formatted address” to the “Limit results around” as in the screenshot below:


This solved the problem of displaying the results, but the results are not narrowed down by the set radius. So that is, even if I set my radius to 100 meters, the search box will display results in other countries.

1 Like

@leonidas.petrou4 - thanks for the suggestion. Seeing the same thing on my end. (Current geographic position’s formatted address yields results, but does not actually apply the radius). Pre-defined addresses (ex. current place’s address) does not yield results.

I’m thinking there’s still something amiss here. Eager to hear from any others if they have their own Google Maps API keys and are able to implement successfully.

@petter, @NigelG, @keith? Any luck?

1 Like

This may be similar to the recent problem with Google Timezone API. Bubble was only signing calls when using Bubble’s key. It was oddly broken when using one’s own key.

There’s some sort of bug here. @Jici built demo projects that show this in another thread. I think it’s busted at the moment and Bubble needs to look at it.


Haven’t had a chance to test this with my own keys, but did a quick test with Bubble’s keys, and the geographical constraint doesn’t seem to apply. It shows results from all over the world.

1 Like

Location restriction works well for me using Bubble’s API key, but not using my own Google API key (which returns results from across the world).

Interestingly, adding “formatted address” actually breaks the restriction for me (ie restriction only works without it).

1 Like

We have updated search results behavior to be more consistent with and without key.

Regarding the radius constraints not applying in some cases, we ran multiple tests and the issue appears to be Google API overriding constraints.

Thanks Neerja. I think there’s some problem when your users are using their own domain.

Using my own domain, it’s still not working for me (using location restriction I get autocomplete results when I don’t input my Google API key into Bubble, but I get no results when I do input it).

However, when I remove my own domain it works fine.

Any chance of a fix?

@george111 Adding your own domain should not impact results. And with the latest fix, you should be able to see the same results with and without key. Try without a custom domain but with key and if you see results, then try with domain and check console for errors.