Popups appearing without trigger

Has anyone experienced this before? There’s this one pesky popup that keeps on appearing without any triggers.

For context, I have two sets of popups that should appear when the “New Projects” button is clicked. One popup is for filling in the details of the project and the other one is for purchasing credits when there are no order credits left.

Conditions for the popups: Project details only show when user credits are > 0 and purchasing credits only display when user credits are < or equal to 0. I also tried varying the conditions to “is 0” and “is not 0”. They are also supposed to appear only on Button Click.

My problem is the popup for purchasing credits appear without a button click and even when user credits are > 1. I have no issues with the popup for Project Details since it displays correctly when credits are >1 and only on Button Click.

And it’s getting really frustrating.

Hi emmanjemuel,

I can’t think of any reason off the top of my head as to why this might be happening, but I think providing a link to your editor will be of help here. Maybe you can clone your app.

Have you tried recreating the problematic popup and see if it still occurs?
Maybe you could change each popup into a group and then add them both into a new popup showing whatever group you need using the conditions you had originally? If that makes sense.


Hi @pork1977gm,

I tried what you said and rebuilt the problematic popup, but it still popped up. I also tried grouping each set of workflows into its own workflow folder and traced each workflow using the debugger.

After hours and hours of frustration, I finally found the little bugger. The popup trigger wasn’t placed on any button but was set to animate on page load.

No more problems. Finally!

Ah I see! I’ve been in similar situation believe me! You can spend ages looking at something only to realise you made some silly little mistake. Glad you figured it out though :slight_smile: