Forum Academy Marketplace Showcase Pricing Features

Repeating group not adding more columns when stretched

Do I have this repeating group setup incorrectly?

I’m working at 320px wide and telling it to stretch and add more columns if the screen gets bigger. But it’s not doing that.

In fact it says the repeating group is already at its maximum width.

This is how the element parameters are set up

Is the parent group restricting the width of the repeating group?

It doesn’t have a parent group. It’s just sitting on the page, which doesn’t have a max width.

Actually I just tried grouping the repeating group, so that it does have a parent group. The group stretches to the same width as the page, but the repeating group stays the same fixed width.

@emmanuel Is this a bug? I’ve found that the repeating group fails to stretch when it doesn’t have a border. If I change nothing else except changing “border style” from “none” to “solid” all of a sudden the repeating group stretches and adds columns like it’s supposed to.

It’s happening here

It’s not happening here

After playing around in a bit (in a cloned page), the minimum cell width was preventing the repeating group from behaving responsively. Changing it from 320 to 100 resolved the issue.

1 Like

Huh…yeah that parameter does seem to control whether or not it adds columns when it stretches. Maybe the border is just invisibly changing the width by 1 or 2 pixels, accomplishing the same thing?

So as long as “cell min width” is less than 320 (in this case) then multiple columns appear when the repeating group is stretched. 320, or 321, or 400, result in only one column even when stretched.

That doesn’t seem like the correct behavior, does it? @emmanuel

When the page is responsive, specify the smallest width the cells can have when the page is resized. When the page becomes too narrow for all the cells to have that width, the repeating group displays fewer cells per row.

The cell min width has to be lower than the element’s width for this to work. We’ll update the reference, we shouldn’t even allow users to do this…

1 Like

I just spent ages trying to figure this out until I came to this topic on the forum. I had my Repeating Group and minimum width set to the same value.

The documentation still doesn’t reflect how it actually works. It only says:

By default, if a repeating group only has one column, e.g., Excel sheet style, no more columns are added when the page is stretched. To change this behavior, check this box.

I think that you should either make it function so that we can only enter 99% like a regular group OR add something like this to the documentation - >This behaviour will only work as expected if the minimum cell width is less than the Repeating Group Width.

1 Like

Sorry to bother you @blueback09 , could you help me out here. I’m able to have more than 1 column added, but the columns won’t continue to be added for the full width of the parent element (which is what I’d want).
Here’s my set-up for the repeating group:
Here’s my set-up for the image inside the repeating group:

Here’s how it looks in preview:

I’d like it to go the full width of the page, which I can weirdly make happen if I make the whole page width 300, which gets me the preview below:

Hi @emmanuel I just checked what I posted above in a new app with a very clean example. Would this be a bug? I’m sorry I’m new to the community, so not sure if this is something I should post as a bug.

FYI the reference is still not updated even 3 years later.

I have spent all morning trying to figure this out, and luckily just now found this thread.

Seems like an easy fix to update the reference to avoid that frustration for others :slight_smile:

@Emmanuel this still doesn’t seem to work?

Hello everyone,

Im having the same issue, in my setup I have a one column RG and it will only repeat 3 to 4 times but never seems to get past 3/4 ths of the page.

In this instance I need to have a one column RG for the functionality Im trying to achieve because I also have other RG;s inside of it but would really like to have it be able to go all the way across the screen.

Setting the Cell min width, did not help in this situation.

EDIT: I supose the answer is use the new responsive system thats in beta :slight_smile: