Forum Academy Marketplace Showcase Pricing Features

RGs don't update when a new item is added

So…kinda strange one. Previously, if I added an item to the DB, the RG that displays all the items in the DB would immediately show the new item. Now, I have to refresh the page before it shows.

Any ideas?

2 Likes

UPDATE: But…if I delete the item it immediately disappears from the RG. The plot thickens…

Yes, I have noticed this issue sporadically over the last several days, but it’s hard to consistently reproduce it. I thought it is because I moved some things server side, but looks like there might be a bigger issue here. If the issue on your is consistent and reproducible every time, then perhaps you could file a bug report so @eve and the bubble team can investigate.

Good shout. I’m glad to know that I am not on my own, @muneer.hameer!

Might be a privacy rule, but absolutely happy to look into this if you could file a bug report! Thanks in advance. :slight_smile:

1 Like

Already done, @eve. It’s 15213. If you go for the runtime test, let me know as you’ll need the MFA code that will get emailed to the duff email address I assigned you…

Thanks for your help!!

1 Like

This issue is confirmed on my end today, and I just filed a bug report. I also filed a bug report in March of 2021 for the same issue.

I sent a detailed screen recording to support. I was able to capture this behavior across three different browsers at once (chrome, safari, edge). It’s certainly an issue.

When I had the same issue in march, I cleared browser history and it solved it (thanks to bubble support). however, today when I cleared browser history the issue persists.

1 Like

Ah, okay. I’ve got a big demo this Friday, so I will try the browser cache thing to see what happens…

No love with the cache clearing, @brad.h , but thanks anyways! I’m pleased it’s not just me…

@steve18, bubble support was not able to reproduce the issue back March. But here’s the instructions I received from @AndrewV in case the issue continued:

If you are still experiencing this, can you try testing this after using the following steps to clear browsing data:

  • Delete your browser’s cookies and cache using the browser’s settings screen. It’s very important to delete both and you will be prompted to log back in to most websites. If you are not prompted to log back into websites where you were previously logged in, this operation was likely not completed correctly.
  • Restart your browser by fully quitting the application and reopening the application. Closing the window or tab alone will not work.
  • Re-open the app’s editor in a Private or Incognito browsing window and gauge whether the issue persists.
1 Like

yeah sorry. I’m not sure the cache clearing worked back in March either. I think time just went by and the issue corrected itself. Otherwise, how would the behavior continue over three different browsers.

1 Like

Thanks pal. Tried all that with no love. Have recreated in both Chrome and Edge (pretty much the same browser) in both incognito and normal modes…

I’ve the same issue, just popped up today. mainly in pulling and pushing the data from the database and it loses the live connection to the database

1 Like

Okay, thanks @basel.adel. It must definitely be an issue…

Same issue. Live connection to the database seems to be interrupted. Users in my app can no longer add items to their carts without refreshing the page. Hope this gets resolved quickly!

1 Like

I noticed this behavior recently also. Following an action that I would expect to produce a new item in a repeating group, eg saving a dB entry,
I display list in repeating group which seems to be an effective workaround. The issue is I imagine this isn’t as efficient as good data binding and using the provided real-time event listeners to automatically update the RG.

2 Likes

This issue is happening to me too. I thought I wrote a new bug but happy to hear it’s not just me. I have a repeating group that loads recipes and when I try to add a new recipe it adds it in my DB but doesn’t add it on the FE until I reload the page.

2 Likes

This one I had but was able to solve it

  • You can assign the list of recipes to repeating group custom state recipes on page load
  • Load the data from this custom state
  • On clicking add, create a new entry in the database and add the item to the list of recipes (result from the previous step)
  • Same with delete, delete the item and then set the repeating group custom state:minus deleted item

It used to read directly from the DB but since yesterday it’s not working, that’s why I used this instead

But not a sustainable solution, it’s always better to read from the DB directly as a single point of truth. but this just a temp fix till we see Bubble response!

Hey pal. I woke up this morning, and it’s now working as normal…