Forum Academy Marketplace Showcase Pricing Features

Send EMail via API Workflow not working

Hey guys,
I would like to send an EMail via an API workflow but it does not work for some reason.

I set up my mails via the sendgrid API in the E-Mail settings section and the normal send e-mail workflow also works totally fine.

I Verified my domain via DNS Records as well as my Mail inside Sendgrid.

The on-page workflow looks like this:

The Backend Workflow looks like this:

API Workflow settings:

Send E-Mail action:

Is there something I ticked which is not supposed to or any other obvious mistake I am making?
I also read other blogs on this topic and followed them through without any success.

Thanks for your help.

Hi @alessandro,

The workflows look good to me. The first thing I’d do is removed all Sendgrid Email settings and tried the simplest email. You need Email settings only to setup the domain, for testing bubble domain should do. If it works with the out of the box config, then it means there’re some issues with either Sendgrid or DNS configs.

Less probable but still possible case could be the recipient’s email provider blocks all emails from Bubble. I have this behaviour with MS Outlook, cannot get any email from any app on Bubble, although a long time ago it had worked fine. As if they just ignore those emails, they’re not even in spam.

Best,
Andrey

Thanks for your reply.

The “normal” send e-mail action relies already on my custom sendgrid API keys as well as my Verified DNS records & verified mail.

If I trigger this action the mail gets send out perfectly fine.

It only does not work unfortunately via the API Workflow set up.

Are you sure Button Success Message is not disabled and clickable and the workflow is really scheduled? You can check if it scheduled by doing the following:

  • Go to Logs → Scheduler and Pause tasks
  • Try the button
  • In the Scheduler click Show to check if the workflow was scheduled

Don’t forget to Resume tasks later on.

Good idea with the button, but its clickable and I can see the workflow being run in the logs :frowning:

Any other idea what it might be?

Thank you so much

Are you sure the receiver definitely exists? Have you tried with a static email address?

If you don’t have a problem with the data either, there is a possibility that the workflow may have been corrupted because everything else seems to be correct.

You should create a new endpoint (not a copy) and test it.

Best,
Eren

are you sure the parent groups user contains an actual user?
check your logs tab to see if there is any info there.