Forum Academy Marketplace Showcase Pricing Features

[Solved] Help with Dropdown

Edited: I just added the option caption as I have it specified, to display a particular text field.
I’m afraid I can’t figure out how to set an existing private app to public.

Sorry for the rudimentary question, but I have a rudimentary problem and I’ve tried everything I can think of.

Here’s a link to the db. If you don’t find the db or the problem, it’s been solved. The problem is on the page called Organizations.

Simple: I’m trying to set a dropdown menu. I want it to load all of the names fields from the Organization type. You will see there are three records in Organization, each with the name field full.

For the dropdown, I have:

Sources Style: Dynamic choices
Type of Choices: Organization
Choices Source: Search for Organization
Option Caption: Current Option’s Name

I want the dropdown to populate with the names of all records of the type (Organizations).

Instead, none of them is being populated. I get one option, with no text.

Can anyone help?

I can’t access your page, it looks like it might not be set to public?

Anyway, I’m guessing you will need to specify that you want to display the Organization’s Name as the text in the drop down. Organization is just an object, and unless you specify a text attribute of the object, nothing will show up. Without being able to get in there, I can’t tell if this is the issue or not :frowning:

couldn’t access it with that link, is it set to private?

Have you set which field you want to show up in the dropdown?

I just edited the original post to show that I am specifying the text field to display, and to ask how I switch an app to public.

under the settings tab on the left hand side of the editor, should be on the first tab that opens up

1 Like

Go to settings > general (first tab) and at the top you should see your app’s privacy settings.

It sounds like you’ve got it set up correctly. Is it possible you added the org data to the live database and not development? Is anything showing up red in the dropdown’s property editor?

1 Like

OK, It’s now set to public for viewing. Have at it. What am I missing?

The data is definitely in the dev database.

Nothing is showing up red.

I’m about 90% sure it has to do with your privacy settings. Looking further. Yeah, it looks like you have a privacy rule on there that only Admins can search for Organizations, so the app is playing by those rules. I would edit your privacy settings and see if that works.

2 Likes

I’m not sure what you mean by privacy settings. Under settings, the first few items control who has access and allows you to set a password. Is that what you meant? I’m set to View access for all, with no password set.

Why would privacy settings affect this?

It’s the Privacy role you set for Organization here:

Right now, under the “Everyone Else” (default permissions) the box “find in searches” is unchecked, as well as the fields that a User can view (Name, Campaigns, Members). If you want Users who’s User Type is not Admin to be able to search for/view fields within an Organization, you would check those boxes.

1 Like

Thank you!

1 Like

Hi, I have this same issue. I have done everything exactly, i have no roles defined, yet my drop down is not populated

can you help me? Please

Thanks

Hi @yetunde.omolola :slight_smile: Sure, can you share a link to the app editor?

Hi, I think i got it but now one of the drop downs is not saving can you help me

thanks so much

No problem! Everything is setup correctly for the dropdowns and the workflow on the Product_ page. I would just add a ‘Reset Inputs’ action after Add is clicked here:

Did you try testing this in preview mode and then click ‘Add’ to create a new Product? I just tested and it looks like all of the information from the dropdowns was saved successfully:

Thanks so so much!!! much appreciated

1 Like