Forum Academy Marketplace Showcase Pricing Features

[Solved] Unable to locate specific elements in show/hide action in workflow

I can’t seem to show certain elements on a workflow that begins with a button on a popup being clicked. Only elements on popups show up on the workflow list, none of the elements on the parent group show up. However, if I create a group within the parent group, rather than a popup, all elements are available on the list.

Elements are also missing for a “do when condition is true” workflow. (see image below)

I am also now getting ‘Show - “bTITU” is not a possible option’ as an error for 2 elements I had setup and shown in the past.

Im guessing there is a new rule/update that I missed that is hiding these elements. Appreciate the clarification.

AJ

You should be able to set up show/hide on button clicks, etc. Must be doing something wrong and I can’t quite tell what based on your explanation.

Perhaps you’re trying to set-up the show/hide from within the workflow and not the action? (based on your screenshot)

If that’s not it, I’d be happy to look at your app to see what’s going on.

Cheers,
Scott

Appreciate the response. But no, I am setting it up with actions as I believe it should be. The screenshot above was just to show an example of the “do when condition is true” workflow that also seems to have an issue with showing all elements.

Here’s more detail on a show elements workflow. It is only listing buttons that are on popups, and none on the parent group.

Hmm. Could it be because those elements are already shown? Can you hide elements like those buttons? …and once hidden the you can use another action to show them?

The buttons i’m looking for are already hidden, they currently do not show on page load.

Its bizarre, cause I haven’t had a problem with showing/hiding elements until now. It seems like it should be straight forward…but it is clear that on the list, it is only showing buttons in pop up groups, and I don’t know why…yet.

Could it be that the buttons are on a group that’s hidden (so it’s the group’s show/hide value that is set to hidden) and the button itself is set to show (but has a parent group that’s hidden so it’s not showing).

As such, the way to show the button would be to show the group.

Its a good thought, but no. I have tried hiding and unhiding the parent group as well to no avail. And really, I would expect the elements to still show up on the list even if the parent group was hidden.

Yeah. I can’t think of anything else.

I’d be happy to look around your app’s editor if you’re able to share it. With that, though, I’m out of ideas for what could be causing it. Seems like quite odd behavior.

One suggestion for problems like this is take a bit of time to figure out exactly which buttons (and other objects) are allowed to be shown/hidden. If it’s definitely showing all popup group items and no other items, then you can focus in on that as the cause. I often find that when I start trying to figure out what’s broken/not broken, that helps be broaden my mindset enough to figure it out.

1 Like

Hey @treeconsultgroup, try re-adding new buttons, new pop-ups, etc to isolate the issue. Check conditions on all the elements involved and even try reproducing the issue on a new page. Sometimes when elements aren’t behaving, I try to recreate it elsewhere to help identify what the problem is. Also, if you share a link, you can get some other brains and eyes on it to help find the cause.

@sridharan.s thanks for the responses…sent you a link to take a look. Here is link for others:

thanks @romanmg. Link posted above

From what I can tell, it looks like it’s because your buttons are inside repeating groups which make them a special case. You can trigger workflows from them (for example, like you already have with the “leave a review” button), but otherwise, you can’t reference that button from outside the group because you wouldn’t be able to specify which button in which cell.

2 Likes

That makes sense. But when you have a popup group, wouldn’t that popup group be associated with the specific cell it is being referenced from?

Either way, appreciate looking into, with that in mind, I’ll play with it and come up with workaround.

Good catch @romanmg.

@treeconsultgroup, the popup might have data from that cell, but the popup itself isn’t tied to the cell. You can still call the popup button with it’s name whereas the elements with repeating groups aren’t referenceable from outside since it’s unclear which button you’re targeting within the RG.

1 Like

Right, @sridharan.s. Popups are independent of whatever triggered showing them. You can open popups from so many other events - when text is clicked, when an input is changed, when the page is loaded, etc.

To display the cell’s data in the popup, you’ll still need to add a “display data” action to define the popup and the current cell’s data.

All makes sense. Just can’t figure out Y it worked before, and only getting these errors now. According to this logic, I must have somehow moved those elements into the repeating group unknowingly. :expressionless:

Well thanks for the assist @romanmg @sridharan.s , Much appreciated.

p.s Taking the elements out of the repeating group gave me 16 other fixable formatting issues, but fixed my killer problem. Huge win!! :slight_smile:

1 Like

The code “bTITU” could be a press release for a new high-energy dance club, but it is more likely to be the internal name Bubble has for a particular element.

I usually get this when doing copy and paste between apps, and there is a reference to an element that wasn’t copied over. It can’t show the “name” you normally see, because the element is missing.

You may have noticed that you can change the “name” of elements, and even have duplicate names, and references to that name automagically get changed. The internal name is how Bubble keeps things consistent.

Still don’t know what the code “bTITU” stands for, but (in my case) it is just referencing a missing element that is currently being used in an action, but for some reason (potential reason being the element exists within a repeating group), it is not available for use anymore. - Just not completely sure why it initially worked and was available for use to begin with.