Stripe error: You may only specify one of these parameters: customer, customer_creation

Help! I’m getting a Stripe error (see screenshot) when I try to charge the current user.

Screen Shot 2022-08-19 at 12.55.56 PM

“Stripe error: You may only specify one of these parameters: customer, customer_creation.”

Here’s the workflow that’s supposed to fire. I tested it with the box for “Authorize the charge only” unchecked and it still threw the same error.

I use Login with Google ONLY for user credentials.

This flow went through successfully all day yesterday and today it started giving this error. I thought maybe it had something to do with the # of orders a single user placed (e.g. if the user tries to trigger this flow the first time, it’s no problem, but if they go thru after that, it throws this error) but yesterday I went through this several times by myself no problem. Today I got my brother to login with his Google and all of a sudden on his second order this error was thrown for the first time ever. Now, when I go back even to my own account, it’s still throwing this error. I can’t manage to complete a successful checkout as ANY user on my app anymore. Help!


Sounds like the same issue…

Help withcharging a user - Bugs - Bubble Forum

Hi there. I had the same error pop up for the first time today. Were you able to get anywhere with this? The fact that it seems to be affecting multiple users for the first time today makes me feel pretty confident it must be an issue with the Bubble Stripe plugin.

Nope, never got anywhere with this, unfortunately. Hoping someone will swoop in and save me…

Any luck? I also encountered same issue, i need to pass, customer and customer_email in create checkout session parameters, and I am getting
You may only specify one of these parameters: customer, customer_email.

1 Like

Well, this is very odd. @bubble told me over the weekend that the broader API workflow issues folks were experiencing on Friday were the root of this error, and they seem to have been resolved on my app. Are you still getting this same error now, even after those issues have apparently been addressed? @goetze.catherine Are you also still experiencing?

Just tried to recreate it and it seems to be working okay… Definitely going to be keeping an eye on this, though. I wouldn’t close it out just yet.

1 Like