Text not actually showing up?

Hello there!

I am creating an app (obviously!) for a community I am a part of.

I have hit a snag in the admin panel I made. It appears as if text I have is not showing up in the test version? I know this sounds weird, so I have made a quick GIF to show what I am talking about. The click behavior is still there, so I know the app is still registering the existence, but not displaying the text?

Any idea’s here? It worked fine yesterday, and I just got back on to try to work on some more stuff and it started happening randomly. No changes were made to it.

Just so you goes know, the texts are in a repeating group, which is searching the users and grabbing the ones who are set as a Mod, Admin, or Master.

1 Like

Don’t worry it’s a bug. (A temporal fix is working for me, check the “Shrink …”

Follow this thread:

Ah! Thank you very much.

Ah Ha I wondered what was going on, text is not visible in Chrome but ok in Firefox. Ok forget that now not visible in Firefox!

Any updates on this, I have a live app with missing text on heading etc… arggg

Mine have re-appeared. Dont know what caused it to, or I would tell you… Sorry.

It comes and goes, refresh you screen… or don’t, just in case :grin: Mine is not coming back at the moment.

Hey @StevenM - quick question/idea on this. Is the text that isn’t being displayed dynamic or static? If dynamic, does the data source for that text box come from a dependent step in a workflow?

It seems that in addition to the actually system downtime, workflows and data processing has been considerably slower over the past few days. When that happens, if you have dependent steps in your workflows (particularly “display Data X in element Y” where X references a previous step in the workflow), I’ve found that the element sometimes won’t display the data because the system is actually still modifying the data from a previous step.

The easiest way to check for this is to run the inspector on whatever element your text isn’t displaying in and scroll down looking for an error message that says the element’s object has been modified and therefore the source data isn’t being displayed.

As a patch until processing times improve, I’ve added a Navigation/Pause for 2000ms step in my workflow. This allowed the data to be written into the first step before the second displayed it in a popup. After doing this, text that wasn’t appearing all day for me has appeared.

Hey @brian thanks for the suggestion! no unfortunately has nothing to do with workflows, but is text headers in a repeating group, but the odd thing is its not all text only some. This only starting happening after the down time earlier today, made not one chnage to live. My suspicions are that a recent update has caused an issue with text elements and similar added to the app prior to a certain date, but I can’t find a common cause!

I just discovered that aything with a hastag # in the breaks the field. It could be certain symbols in the data are breaking bubble???

Ok… no one sneeze! :anguished:

I am having the exactly same problem: table headers text not showing up. TEST and PROD. I’ve also tried multiple things to see if it was something on my side, but nothing.

Have you already submitted a bug report?

Apparently a bug report or two has been submitted see here: All Apps Down. Can not access anything!

It sometimes comes back, but yes my header text and some of the static text in repeating groups.

But I fear no one is there until tomorrow.

I found a way to reproduce it. In my case the headers do not show up when the repeating group’s layout style is set to full list. Whenever I use anything else, it works.

Ah HA! Nice find! Yep I get the same when I change from full list to anything else!

@rico.trevisan did you submit a bug report with the find?

My text does not show if it is set to Fixed width within a Repeating Group - if I change it to 99%/constrain at 100% it does show - BUT ONLY if I move my browser window inwards and outwards again or rotate ipad from landscape to portrait and back.

Just about to demo my app to a client - so this could cost me a customer.

For me it happens at both full list and fixed cell repeating group, test and prod.

I submitted a bug report at least with the missing text issue.

Really need fixed, I’m demoing my app tonight!

Did it just start happening for you today? I have noticed some-weird stuff going on with my repeating groups.