Forum Academy Marketplace Showcase Pricing Features

Text search --bug?

Help! - I’ve got major search woes. I have an ordinary text field that will not return search results if I type more than 2 letters. - And even the 2 letter search is inconsistent. (it will sometimes return a single result, though there are several matches)

At first - I noticed my “search$autocorrect” plugin was no longer returning any results (even with the threshold set to 1! - should show ALL items)

Then I abandoned the plugin and tried a simple Input with Repeating group constraint.

As an example, if I start to type with the letter “b” -my repeating group returns x4 results (though there are more than 4 book titles with a “b”)

if I add an “r” it returns a single result – looks like the first match – even though there is more than 1 title with a “br.”

This is just an example - basically - of I type 1 letter I’ll get a partial list and if I add a letter or two - I get no results. :man_shrugging:t2:

Any ideas?

:pray: - Tom

Wow - I have no idea why this is the case - but it turns out the search only works if the input is Visible on page load.
I was revealing the input with a workflow - and for whatever reason -that breaks the search.
:man_shrugging:t2:

Have you checked your privacy rules?

Hey Johnny - thanks for the response! - Some forum digging did lead me to check out the privacy rules, and I do have a rule on the data type, but I tried deleting the rule entirely and that didn’t work.


but - I still feel like this might be related.
Any idea why setting the Input element to Visible on Page load somehow solves everything?

I’m running the app preview as the User who created the Reading Log entries. (obvi) :slight_smile:

This topic was automatically closed after 70 days. New replies are no longer allowed.