Forum Academy Marketplace Showcase Pricing Features

Problem with ZQ Fuzzy Search and autocomplete

Hello, @natvancleve
Thanks for reaching out.

In order to investigate your case, can you please provide us with next details:

  • Please send the screenshots of all the elements ( input, RG, and plugin element);
  • Describe your idea on how exactly are you using our plugin;
  • Let us know, if there is any plugin, you are trying to use together with this one/

All this information will help us to analyze the root cause of the mentioned error.

We are looking to hearing from you soon.
Best regards,
Zeroqode Support Team




I’m just using this plugin to do fuzzy search.

I’m not trying to use fuzzy search together with another plugin. I just meant I have other plugins installed and I’m wondering if there is a conflict.

Thank you!

Hello, @natvancleve
Thanks for these details.

As we can see, you have a lot of conditions for your RG and input. Please make sure that you don’t have conditions that contradict displaying all the data.

Also, you need to add the “Show Search&Autocorrect” action on the page load. It’s because the input element you are using to search is loaded before Search&Autocorrect.

Please try this hint and let us know about your result.

Best regards,
Zeroqode Support Team

Didn’t work. The search and autocorrect element is visible. But it’s not grabbing the value from the input box.

By any chance was this Search&Autocorrect element copied from another page? I’ve had a weird issue where it never takes the input value then I think placing a new element and doing everything again fixed it

1 Like

Hello, @natvancleve
Thanks for these details.

@tylerboodman Thanks for a good input here. This really could solve the issue.
@natvancleve Please try the method, described above. If it still doesn’t help you, can you please add our Support Team email to the list of collaborators to your application and provide us a link to your application? This will allow us to check your settings and run some tests and define if it is possible to use your default settings for that.

To add our Support Team as a collaborator, you need to do the following steps in the Bubble Editor:

Settings > Collaboration > Add email [email protected]

Note: ignore the warning message regarding the plan, as we are an agency and you can easily add us to your collaborators.

Looking to hear you soon.
Best regards,
Zeroqode Support Team

Hi team! I’m also having issues with any results loading on my page:

  1. Linking Input element to Fuzzy Search isn’t working
  2. Search works when I put Text Match as Input element value, but it won’t show any results

Can someone please help? I can DM you my login info.

Thanks,
Macy

1 Like

same here

Hi @macyhong7 @daviddr17,
Thank you for your messages.

Can you please share screenshots of your setup, the plugin element, the input you are using, and the ID Attribute set?
Also, please check the conditionals of your Repeating Group showing search results and compare it with the Screenshot below:

Please try adding the same conditional and let us know if that will solve the issue with the Fuzzy Search plugin. For additional setup guidance, please check the plugin demo editor page:

Let us know the Bubble version you are using :pray:

Looking forward to your reply.
All the best, :slightly_smiling_face:
Zeroqode Support Team.