Forum Academy Marketplace Showcase Pricing Features

☁️Wasabi Cloud Storage Plugin

:raising_hand_man: I upload a picture on your demo, but it is not recorded in the database, although the last entry is on June 10. Could you put together a simple interface for uploading files to wasabi and saving a link to this element in the bubble database and describe everything step by step? Please help me!

@mirco I have this same issue…

If you scroll up this topic, you will see that I have problems with this plugin for almost 21 days…
And before you ask, yes, it is updated.

Really need help here @levon and @ZeroqodeSupport

Hi @mszaxaroff, thanks for your appreciation.

Considering that each use case and project requirements are unique, it would be quite difficult to develop a ready-made interface that would meet major demand. Each user, guided by plugin supporting documentation and Live demo example, can build his own case/interface.

Unfortunately, you still need to adjust the settings and workflows accordingly to your particular pages.

As a reference and example of interface and process configuration, we advise using the plugin Live Demo page: https://appkit.bubbleapps.io/wasabi

We are really sorry for the inconveniences created by the usage of our plugin :pray:.
In a short time, a small bugfix will come to live, that should fix this issue. We will let you know when you will need to update your plugin.

Thank you for understanding.
Regards,

Zeroqode Support Team

1 Like

Hi @mirco & @rpetribu, thanks for your patience and understanding :pray:
As mentioned earlier, we have made a small bugfix that should solve the abovementioned issue.

Please upgrade the plugin to the latest version (1.49.0 - fixed issue with uploading files in folders from backend), refresh the application, and give it a try.

In case the issue will persist or any other plugin-related questions will appear, please let us know.
Regards,

Zeroqode Support Team

1 Like

In this demo, it does not write to the bubble database.


In my app, a record is created with some data, but no URL is recorded


Hi @mszaxaroff , thanks for your message.

Thanks for noticing this issue, it is related to the demo page responsive settings, and in a short time it will be corrected.

Please check the Foreach element settings, to have the following setup and also compare the general workflow settings with the demo page.

In case the issue will persist, would it be convenient for you to add our [email protected] as a collaborator of your app?

Enter your Bubble editor page → Settings → “Collaboration” tab → Invite a user (email).

(Note: you can add our support account to the collaborators list even if your app is on a Free/Hobby plan.)

We will check your setup and do a few tests in an attempt to find the root cause and help you fix it.
In case it is ok for you, please let us know.

Regards,

Zeroqode Support Team

1 Like

@ZeroqodeSupport

This issue was solved? I am having the same problem…
I can’t retrieve any file. Already checked everything twice.

Do you have an example of this action working? I didn’t found…

1 Like

Hi @rpetribu, thanks for your question.
Please accept our apologies once again :pray:

One more small bugfix, related to this feature, will come to live in a short time. Once the update will come to live, we will let you know.

Thank you for understanding.
Regards,

Zeroqode Support Team

2 Likes

Thanks! :+1:

1 Like

Thank you very much! Now everything works! Can you tell me how I can make the file display in my application? For example, an image. I substituted the path statically, then made the output dynamically from the Bubble database and through the plugin, specifying show the last URL, but the picture is not displayed. What could be the problem?

Hi @mszaxaroff , thanks for your feedback.

Allow us to analyze it internally and come back with a reply asap.

Have a nice weekend ahead!
Regards,

Zeroqode Support Team

2 Likes

Hi @mszaxaroff, thanks for your patience.
In order to display an image on a page, please be sure that the privacy settings of the uploaded file are set correspondingly, and the Private field is “No”.

Please check on your side and provide feedback if this information helped you. If the image is still not showing properly, please provide screenshots/screencast with more details of your setup. This will allow us to identify the issue faster.

@rpetribu & @mirco, thanks for your patience and understanding.
As mentioned earlier, we have made a small bugfix that should solve the issue with retrieve file action.

Please upgrade the plugin to the latest version (1.50.0 - fixed an error in retrieve file action), refresh the application, and give it a try.

In case the issue will persist or any other plugin-related questions will appear, please let us know.
Regards,

Zeroqode Support Team

1 Like

Hi! Thank you very much! Everything works! I also connected the paid wasabi tariff to make sure it works! You’ve been very helpful) You’re cool! :star_struck: :+1: :clap: :clap: :clap:

1 Like

@mszaxaroff glad to hear it works and you’re welcome :wink:

If you like our plugin you can rate it by going to the Plugins tab in Bubble editor.
Find the plugin by name and it gives it as many stars as it deserves :slightly_smiling_face:

The more feedback we get, the more motivated we are to make things better in Bubble.
Have a nice week ahead!
Regards,

Zeroqode Support Team

1 Like

It looks like there is some problem with the ForEarch plugin, Bubble gives an error. How often can this happen?
If my users can’t upload videos for a while, this could be a serious problem…

@ZeroqodeSupport , sorry for the last comment!
I made it work… it appears that I was with some strange internet problem…

Every issue I had was solved :grinning:

Thanks!

1 Like

Hi @mszaxaroff, thanks for your message.

The mentioned errors related to the fact that the default delay that is introduced on the Live Demo page for the “ForEach” element is too small for big-size files.
For your use case, if big-size videos are uploaded, you can change the delay time accordingly.

Hi @rpetribu, glad to hear that it is working now :slightly_smiling_face:

If you like our products and support, feel free to rate us on TrustPilot Zeroqode Reviews | Read Customer Service Reviews of zeroqode.com

The more feedback we get, the more motivated we are to make things better in Bubble :hugs:.
Take care!

Zeroqode Support Team

1 Like

Understood, thank you so much for your answer! :+1:

1 Like

Hi,
I confirm that uploading to folders is now working.

however, I found additional issues which still make the plugin unusable to me:

  1. If the prefix field is empty, the plugins adds the string “api_call_” to the beginning of all filenames.
    expected behaviour is to not add any prefix string.

  1. if the filename already exists, the old file gets silently overwritten.

bad things happen when you silently overwrite files.

expected behaviour is to throw an error and let the user decide wether to cancel/overwrite/rename.
if not possible, a configurable option to overwrite or rename the file would work (i.e. add a “2” at the end)

2 Likes